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Chapter 1   Getting Started with 
NanoScope v6.12 Software

The focus of this manual is the NanoScope software version 6.12. It is a reference to the tasks 
related to your NanoScope system. The material provides an overview (i.e., theory and 
applications), procedures, interface definitions and optimization tips.

Refer to the following sections to begin to understand the NanoScope software:

• Installing the NanoScope Software: Section 1.1

• Getting to Know the NanoScope Software: Section 1.2

• Setting up the Workspace Section 1.3

• Quick Guide to a 4K Point Image: Section 1.4

• Using Online Help: Section 1.5

• Technical Support at Veeco: Section 1.6

1.1 Installing the NanoScope Software

1.1.1 System Requirements

The 6.12 version of software requires the following:

• A minimum computer configuration of 600MHz (800MHz recommended)

• 256Mb RAM (512Mb recommended)

• G450 Video (G550 Video recommended)

CAUTION: Contact Veeco Technical Support (see Contact Information Section 
1.6.2) before attempting to increase the RAM of your system. Failure 
to do so could cause irreparable damage to your system.
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1.1.2 Before You Install

1. If you are upgrading from a previous version of NanoScope, ensure you are starting with a 
working version. The settings from the working version will be used for the new version.

2. Note that some of the installation screen views may not appear, or may appear slightly 
different, depending on your particular system configuration.

3. Make sure you have downloaded and installed NS Toolbox. This is available on the 
NanoScope 6.12 CD or from the Veeco FTP site (contact Veeco for more information).

4. Make sure you are logged in as Administrator on the local workstation.

1.1.3 NanoScope 6.12 Installation

Note: Most systems are configured on the microscopes prior to delivery.

1. Insert the NanoScope 6.12 CD-ROM in your CD drive, open the CD-ROM files, open the 
v612 folder, and select the Setup.exe icon. 

If you do not have Administrator privileges on your workstation, a WARNING will appear on the 
screen and installation will discontinue (see Figure 1.1a).

Figure 1.1a   Administrator Warning

2. The Welcome to NanoScope 6 dialog box will open (see Figure 1.1b). Click Next.

CAUTION: Ensure you have backed up all critical data onto external media before 
installing the NanoScope 6.12 software.
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Figure 1.1b   Welcome to NanoScope 6 Dialog Box

3. The InstallShield will display system requirements and recommendations (see Figure 1.1c).

Figure 1.1c   System Requirements and Recommendations Dialog Box

4. The User Information dialog box will open (see Figure 1.1d). Enter the required 
information in the appropriate spaces, then click Next.
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Figure 1.1d   User Information Dialog Box

5. The Enter Information dialog box will open (see Figure 1.1e). Enter the letter of the drive 
where you wish to install the NanoScope 6.12 software and click Next.

Figure 1.1e   Enter Information Dialog Box

6. The Installation Type dialog box will open (see Figure 1.1f).

a. To install the NanoScope 6.12 software for the first time, select Full Installation and 
go to 1.1.4, "NanoScope 6.12 Full Installation Procedure".
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b. To upgrade your existing NanoScope software to version 6.12, select Upgrade 
Installation and go to 1.1.5, "NanoScope 6.12 Upgrade Procedures".

Figure 1.1f   Installation Type Dialog Box
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1.1.4 NanoScope 6.12 Full Installation Procedure

1. A second Installation Type dialog box will open (see Figure 1.1g). Select Standard, then 
click Next to continue the installation.

Figure 1.1g   Installation Type Dialog Box

2. The Select Microscope dialog box will open (see Figure 1.1h). Choose the installed 
microscope and click Next.

Figure 1.1h   Select Microscope Dialog Box
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3. The Select Components dialog box will open (see Figure 1.1i). Choose the required 
components from the list by clicking on the adjacent check box(es) and then click Next.

Figure 1.1i   Select Components Dialog Box

4. The Select NanoScope Controller Type dialog box will open (see Figure 1.1j). Choose your 
NanoScope Controller type from the list and click Next.

Figure 1.1j   Select NanoScope Controller Type Dialog Box
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5. The Select Program Folder dialog box will open (see Figure 1.1k). Use the defaults, or 
change the program folder names as desired, and click Next.

Figure 1.1k   Select Program Folder Dialog Box

6. The new software will start installing, the NanoScope Setup dialog box will open, and the 
software installation progress indicator will show installation progression (see Figure 1.1l).

Figure 1.1l   NanoScope Software Installation Progress Indicator



Getting Started with NanoScope v6.12 Software
Installing the NanoScope Software

Rev. C Nanoscope Software 6.12 User Guide 9

7. One of two Setup Complete dialog boxes will open.

a. If you chose to install the Frame Grabber driver in Step 5, the Setup Complete dialog 
boxes (see Figure 1.1x) will inform you that you must restart your computer before 
being able to use the new NanoScope software. Select the Yes, I want to restart my 
computer radio button.

Figure 1.1m   Setup Complete Dialog Box With Frame Grabber

b. If you chose not to install the Frame Grabber driver in Step 5, the Setup Complete 
dialog box (see Figure 1.1y) will inform you that setup is complete. If you wish to start 
the software immediately, click the Click here if you want to launch NanoScope 
check box.

Figure 1.1n   Setup Complete Dialog Box Without Frame Grabber
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1.1.5 NanoScope 6.12 Upgrade Procedures

1. If you selected to upgrade an existing version of NanoScope, an information box will open 
explaining the use of the calibration and parameter files (see Figure 1.1o). Click the OK 
button.

Figure 1.1o   Information Box

2. The Source folder for upgrade dialog box will open (see Figure 1.1p). If your old software 
is installed in the default directory, click Next, or enter the directory of the old software and 
click Next.

Figure 1.1p   Source Folder For Upgrade Dialog \Box

3. If there is an existing directory of this software version on the chosen drive, an information 
dialog box will open explaining that the files will be overwritten and instructing you to 
rename the directory before proceeding if you wish to preserve it (see Figure 1.1q). Click the 
OK button to continue the installation.



Getting Started with NanoScope v6.12 Software
Installing the NanoScope Software

Rev. C Nanoscope Software 6.12 User Guide 11

Figure 1.1q   Repeated Directory Name Indicator

4. A progress box (see Figure 1.1r) will open showing the copying of the old files by the 
upgrade. 

Figure 1.1r   Copy Files Progress Box

5. When copying is complete, a Question dialog box (see Figure 1.1s) may open, asking if you 
wish to install the Frame Grabber driver. If you have a Frame Grabber card installed on your 
system, click Yes, otherwise click No.

Figure 1.1s   Frame Grabber Driver Question Dialog Box

6. The Select Program Folder dialog box will open (see Figure 1.1t). Use the defaults or 
change the program folder names as desired and click Next.
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Figure 1.1t   Select Program Folder Dialog Box

7. The NanoScope 6.12 software will begin upgrading and a progress box will appear (see 
Figure 1.1u).

Figure 1.1u   Upgrading 6.12 Progress Box

8. At approximately 95% progress, the NanoScope ODBC Setup box will open (see Figure 
1.1v) and install the Desktop Database Drivers.
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Figure 1.1v   NanoScope ODBC Setup Box

9. Upgrading will then continue. If you chose to install the Frame Grabber Driver in Step 5, it 
will be installed at this time (see Figure 1.1w).

Figure 1.1w   Frame Grabber Driver Installation Progress Indicator
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10. One of two Setup Complete dialog boxes will open.

a. If you chose to install the Frame Grabber driver in Step 5, the Setup Complete dialog 
box (see Figure 1.1x) will inform you that you must restart your computer before being 
able to use the new NanoScope software. Select the Yes, I want to restart my 
computer radio button.

Figure 1.1x   Setup Complete Dialog Box With Frame Grabber

b. If you chose not to install the Frame Grabber driver in Step 5, the Setup Complete 
dialog box (see Figure 1.1y) will inform you that setup is complete. If you wish to start 
the software immediately, click the Click here if you want to launch NanoScope 
check box.

Figure 1.1y   Setup Complete Dialog Box Without Frame Grabber

11. Click the Finish button.



Getting Started with NanoScope v6.12 Software
Getting to Know the NanoScope Software

Rev. C Nanoscope Software 6.12 User Guide 15

1.2 Getting to Know the NanoScope Software

Start the NanoScope software by double-clicking on the desktop shortcut labeled NanoScope 6.12.

1.2.1 Software Interface

The NanoScope software contains two modes of operation: Realtime (i.e., all operations related to 
controlling of the microscope) and Image Processing or Offline (i.e., analysis and modification of 
captured images). In previous versions of NanoScope software, these modes were separate work 
environments. With version 6.12, both work environments have been combined into a “workspace.”

1.2.2 What is a Workspace?

A workspace is a configuration of views and parameters in the NanoScope software. Within the 
workspace window, the user configures a hierarchy of commands (i.e., nodes) for running the 
microscope and processing images. Auto programs are run in the order that commands are 
configured. 

The behavior and appearance of the workspace window may be controlled using the Workspace > 
Preferences menu or by right-clicking in the workspace window.

Figure 1.2a   Workspace Nodes

Parent
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Child
Node
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Nodes

The top level node is known as the parent node and each node underneath is known as a child node 
(see Figure 1.2a). Parent nodes are usually the name for the microscope mode (e.g., Realtime) or a 
file name of an image within the workspace. Parent nodes are the higher level nodes for auto 
programs. Child nodes, also known as “views,” are typically associated with a window that is used 
to carry out an analysis, image processing, or Realtime control function of the software.

Each node may be renamed, deleted and grouped. Node names may be preceded by an icon and/or 
lines indicating the relative positions of nodes in the hierarchy. 

1.2.3 The Main Screen Elements

Start the NanoScope Software

Complete the following to open the NanoScope software: 

1. Double-click the desktop shortcut labeled NanoScope 6.12. 

2. The default screen appears with menu items (File, View, Help, etc.), a blank workspace and 
a toolbar (see Figure 1.2b).

Note: Select File > Open Workspace to open a previously created workspace file.

Workspace Window A dockable window in the client window for viewing and configur-
ing a series of views.

Client Window A central window for viewing all Realtime graphical displays, input 
parameters, results parameters and graphs.

Menu Bar A group of items for executing commands or viewing files.

Toolbar A group of icons for executing commands or viewing dialog boxes 
to configure input parameters.

Status Bar A read only list that displays the stage X, Y, Z coordinates and 
enabled functions (e.g., Capture: On).

RT Status Window A dockable window in the client window displaying information 
about the sample during Realtime.

Browse Window A dockable window in the client window for browsing files. Avail-
able in list or thumbnail format. 

Help Window A dockable window in the client window for displaying the Help 
screen.
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Figure 1.2b   Screen Elements

Functions Menu

The Functions menu is accessed by right-clicking on a parent node (i.e., Realtime or a filename). It 
includes specific elements for viewing multiple windows, renaming views, grouping views, and 
adding and deleting views. This menu also includes the command for running an Auto Program 
(i.e., Run AutoProgram) where the image processing commands may be run in a series on 
multiple images and results may be saved in a data file (see Figure 1.2c). 

Figure 1.2c   Functions Menu
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 Menu Items

Add View Accesses a submenu of Realtime or offline commands.

Add Group Adds a Group node to the workspace for creating a defined set of 
commands. 

Delete Deletes the currently selected node in the workspace. If changes 
were made, a prompt appears to save the view.

Delete Sub Items Deletes the items listed under the currently selected node in the 
workspace. If changes were made, a prompt appears to save the 
view.

Change Title Allows for the selected view title to be changed.

Permit Multiple Views Selecting this item allows for multiple views to appear in the client 
window (see Figure 1.2d).

Assign File TBD

Create Auto Program Allows you to create a new Auto Program based on analysis done 
on a node. 

Edit AP Attributes If the currently selected node is in Auto Program, this parameter 
allows you to edit the Auto Program properties.

Run Auto Program Accesses the Auto Program Results view to run the selected image 
processing commands. 
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Figure 1.2d   Permit Multiple Views

Functions Submenu

The Functions submenu allows for adding new views to the workspace in the Add View command 
(see Figure 1.2e). 

Figure 1.2e   Realtime Workspace Functions Submenu
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Functions Submenu Items

The Add View submenu includes commands for running the microscope, analyzing and reporting. 
Selecting a command adds the item name and icon as a new child node to the workspace window. 
Click on a node to invoke the view in the client window. 

Depending upon the microscope type and mode (i.e., Realtime, Image Processing and Profiler), 
each workspace has unique commands in the Add View submenu. For the Realtime functions Add 
View submenu, see Figure 1.2e. For more detailed descriptions about the views, see Chapter 2.

Quick Key Commands

Many commands have quick key commands (series of keys to enter in place of using the mouse).   
You can open menus, access panels and execute commands with the keys or combination of 
keystrokes. In the NanoScope software, the quick keys are designated by an underlined letter in 
the command name (e.g., R is the quick key in Realtime). 

To activate a quick key command, press the Alt button then the quick key, or select the command 
with the mouse and press the indicated quick key. 

Quick keys only apply when in an active box, menu, panel or window that is currently visible on 
the screen. Active panels are designated in color with a highlight on the panel title or with a heavy 
frame around the panel.

1.2.4 Menu Bar Items

The initial menu bar includes: File, View and Help to begin the process of initializing and opening 
files in the client window. Once a workspace is open an expanded toolbar exists for running and 
configuring the microscope to scan or process images.

The menu items include:

• File—Accesses menu selections for opening, saving and printing files and documents.

• View—Accesses menu selections allowing to choose display properties.

• Format—Accesses menu selections for opening the Note and Color Scale options.

• Realtime—Accesses menu selections to administer commands during data collection.

• Acquire—Accesses all Realtime Views.

• Analyze—Accesses all Offline Views.

• Tools—Accesses menu items for selecting and calibrating various settings.

• Window—Accesses menu selections for arranging windows.
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• Help—Accesses menu items for initializing and displaying the help screen, a Bug 
Report dialog box to submit bugs/requests to Veeco, and NanoScope information about 
your system.

1.2.5 Cursor Types

Within captured images, it may be necessary to do analysis or modification on a selected area or 
exclude this area from the analysis. Cursors allow for specifying this information.

The cursor types are as follows:

• Lines—Selecting specific data (e.g., lengths of features or sectioning features) along the 
line.

• Boxes—Selecting specific areas on the display for including or excluding data.

• Grid Markers—Horizontal or vertical line cursors within histograms and spectrum 
graphs for choosing data ranges or making measurements. 

Using a Slider Cursor

In a graph or histogram, position the mouse with in the blank area between the axis and the edge of 

the graph and drag the slider along the graph to position the cursor. The cursor will change to .

Positioning a Line or Box Cursor

• Click and drag the image to draw a line or box cursor. 

• To resize an existing line or box cursor, click and drag on a corner edge or end of the 
object. Cursor will change to  or .

• To move an existing object, click and drag the center of the object to the desired 
location. The cursor will change to .
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1.3 Setting up the Workspace

1.3.1 Create or Open a Workspace

1. A workspace can be opened or created by selecting the following:

• File > New Workspace.

• File > Open Workspace and browse to open an existing workspace.

• File > Select the Workspace Name from the Recent files list.

Note: A new blank space will automatically display when version 6.12 is opened.

2. To begin Realtime operations, open a Realtime node. Select Realtime > Start Realtime or 
click the NanoScope icon.

A Realtime mode appears in the workspace, along with a dialog box allowing you to add views to 
the Realtime node.

1.3.2 Add Views and Configure the Workspace

1. Position the mouse on the Realtime icon and right-click to view the functions menu (see 
Figure 1.3a).

2. If one of the views (Scan-Single, Scan-Dual, or Scan-Triple) does not appear 
automatically, in the functions menu, select Add View and one of the scan views or click the 
Scan button.

3.  Add the following views to your workspace to set up the hardware for scanning:

• Meter View—for verifying the laser signal on the cantilever. (If desired, the Realtime 
Status Window can be opened in place of Meter View).

• Navigate View—for setting the tip to sample focus, locate tip and stage alignment (not 
present for MultiMode).

4. Customize your workspace with any additional views using the same procedure as in Step 2.

Note: In the Functions menu, select Permit Multiple Views for allowing several 
windows to display.
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1.3.3 Multiple Users using NanoScope

The NanoScope computer can save multiple user preferences/settings in the computer registry. 
Once a user sets up an account on the computer, several settings are automatically saved for the 
user. These settings include:

• Previous image file type

• Browse window settings

• Option to disable video while scanning

• Section View results

• Location of Abort dialog box

• Review curve settings

• Force Filter settings

• Help settings

• Script directory

• Track ball on

• Default Parameter dialog box location

• Point and Shoot View settings

• Sweep dialog box settings

• Workspace settings

• Image control settings

• Grid control settings

• Meter View control settings

• Color control settings

• Z center control settings
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Figure 1.3a   New Realtime Screen
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1.4 Quick Guide to a 4K Point Image

The following procedures provide quick steps for using the NanoScope 6.12 software. Follow these 
steps to quickly scan a sample and then capture and analyze an image. Along the way, you’ll see 
how the NanoScope 6.12 software works, learn some useful tricks, and find out how to learn more 
later.

If you have used the “classic” NanoScope software, you’ll see that the new interface is Microsoft 
Windows-based.

This section is not intended to teach a new user how to run an AFM, but only to introduce 
experienced users to V6.x.

1.4.1 Starting the NanoScope Software

After the software installation is complete, you are ready to start the NanoScope software and add 
some views to the software workspace.

1. To start the NanoScope software, double-click the NanoScope 6.12 startup icon on the 
computer desktop. You will see the NanoScope software window (see Figure 1.4a), which 
can span one or two monitor displays. This large window will contain all the areas and views 
you use to control the microscope and analyze your results.

Figure 1.4a   NanoScope Software Window

2. Notice the white area on the left side of the NanoScope software window. This white area is 
the “workspace.” This area acts as an organizer for operations you use in the software—
including scanning and analysis. Each item in the workspace has a view window that lets you 
set parameters, perform actions, or view results. The sequence of items in the workspace is 
important only for Auto Programs that use analysis functions.
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3. Select Tools > Select Microscope to open the Microscope Select dialog box.

Figure 1.4b   Microscope Select Dialog Box

In the Microscope Select dialog box:

a. You can add a new set of hardware configuration parameters by clicking New, or edit 
the parameters of the selected microscope by clicking Edit. The parameters include 
things such as the controller, extender, and vision system.

b. In the Equipment dialog box, choose the microscope you are using (see Figure 1.4c). If 
you are using a MultiMode AFM, select the scanner you plan to use (Scanner button). 

Note: Select the Advanced button to view all equipment parameters.

Figure 1.4c   Equipment Dialog Box



Getting Started with NanoScope v6.12 Software
Quick Guide to a 4K Point Image

Rev. C Nanoscope Software 6.12 User Guide 27

4. Click the yellow Realtime icon in the toolbar. This adds a “Realtime” group and a Scan 
View to the workspace. It may take a moment the first time Realtime is added. A dialog box 
(see Figure 1.4d) will appear giving you the option to add more views.

Figure 1.4d   Add Realtime Views Dialog Box

5. Right-click on Realtime in the workspace and select Permit Multiple Views from the pop-
up menu. When this item is enabled (that is, has a check mark next to it), you can have 
several views open at the same time.

Note: Areas in the NanoScope software window can be resized and moved to make it 
easier for you to use. When you reopen the software, it will remember your 
changes. Drag the edge of an area to resize it. Drag the title bar or double raised 
lines on an area to move it to another edge of the window or to make it a 
floating window. (In Microsoft Windows terminology, these areas are 
“dockable.”) Click the “X” in the upper-right corner to close an area. Use the 
View, File, or Scan menu to open an area. For details about the areas of the 
NanoScope software window, see Section 1.2.

If you are using a Dimension Series AFM, continue with the steps in Preparing a Dimension Series 
AFM for a Realtime Scan. If you are using a MultiMode AFM, skip to Scanning and Scan 
Parameters Section 1.4.4.

1.4.2 Preparing a Dimension Series AFM for a Realtime Scan

Once you’ve created the workspace, prepare the system to scan. This includes selecting the 
operation mode, aligning the laser, adjusting the photodetector, locating the cantilever tip with the 
optical microscope, and focusing the optical microscope on the surface. If you have not yet learned 
these procedures please refer to your Dimension Microscope Manual and/or SPM Training 
Notebook.

For details on using the Realtime Scan Views, see Chapter 2.
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1. Click Scan in the workspace to see the Scan View. In the Scan View parameters area, select 
the Other tab. Set the Microscope mode parameter to Tapping or Contact.

2. Mount the probe into the cantilever holder

3. Mount the cantilever holder onto the end of the scanner head.

4. Align laser on cantilever.

5. Click Meter in the workspace to see the Meter View. Turn the two screws on the side of the 
scanner to adjust the laser position in the photodetector. In the Meter View, the location of 
the red dot and the values at the bottom of the display change.

6. Click Navigate in the workspace to see the Navigate View. This view shows the video and 
stage controls. Activate the track ball by clicking on the Track ball ON button inside the 
Navigate View.

7. Click the Locate Tip icon in the toolbar or the Locate Tip button within Navigate View. 
Using the two adjustment screws to the left of the optical objective of the microscope, center 
the tip of the cantilever under the crosshairs.

8. Focus on the tip end of the cantilever either by using the trackball while holding down the 
bottom-left button or by using the Optical Focus mouse controls. Click and hold the large 
arrow keys to move the focus up or down. The speed is controlled by the sliding bar or by 
typing a value from 0 to 100. Click OK to set the focus and enter Focus Surface mode.

When you leave Locate Tip mode, the optics move to a focus position, typically 1mm below 
the tip. To set this, select Tools > Engage Settings > General > Motor.

9. Focus the optics on the sample surface using either the trackball or the Z Motor arrows in 
the Navigate View. To use the track ball, set the trackball to On, and roll the trackball up or 
down while holding down the bottom-left button. To use the Z Motor arrows, click and hold 
them down. You can use the speed controls in the Z Motor area to adjust the speed. This 
adjustment raises or lowers the Z stage on which the SPM and optics are mounted.

10. Move the x-y stage to align the desired location on the sample under the crosshairs either by 
using the trackball without holding down any buttons or by using the XY Stage arrows in the 
Navigate View.

11. If you are using TappingMode, click the Tune icon. Check your parameters in the Auto Tune 
list.

12. Click the Auto Tune button. Notice that the status bar at the bottom of the NanoScope 
software window says “Cantilever Tuning” during automatic tuning. When tuning is 
complete, click Exit in the Cantilever Tune dialog box. Proceed to Section 1.4.4, "Scanning 
and Scan Parameters".
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1.4.3 Preparing a MultiMode AFM for a Realtime Scan

Once you’ve created the workspace, prepare the system to scan. This includes selecting the 
operation mode, mounting the probe, selecting the scanner, mounting the sample, aligning the laser, 
and adjusting the photodetector. If you have not yet learned these procedures, please refer to your 
Multimode Manual and/or SPM Training Notebook.

1. Click Scan in the workspace to see the Scan View. In the Scan View parameters area, select 
the Other tab. Set the Microscope mode parameter to Tapping or Contact.

2. Change the mode switch on the base of the microscope. Set it to TMAFM if you are using 
TappingMode. Set it to AFM & LFM mode if you are using Contact mode.

3. Mount the probe into the cantilever holder.

4. Put the cantilever holder in the optical head. Secure the holder by tightening the screw in the 
back of the optical head.

5. Choose a scanner (A, E, or J) by clicking on Tools > Select Scanner. Mount and plug the 
scanner into the base. Attach the corresponding springs to the microscope base. 

6. Mount sample onto scanner.

7. Place optical head on scanner, making sure there is enough clearance between the tip and the 
sample.

8. Align laser.

9. Adjust the photodiode signal.

10. If you are using TappingMode, click the Tune icon. Check your parameters in the Auto Tune 
list.

11. Click the Auto Tune button in the Cantilever Tune dialog box. Notice that the status bar at 
the bottom of the NanoScope software window says “Cantilever Tuning” during automatic 
tuning. When tuning is complete, click Exit in the Cantilever Tune dialog box.

1.4.4 Scanning and Scan Parameters

Next, you set scan parameters and scan the sample.

1. In the Scan View, use the following initial parameter settings in the Scan tab. These values 
may already be set; they are handy starting values.

Scan size: 1µm

Aspect Ratio: 1.00

X offset: 0nm

Y offset: 0nm
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2. Most of these commonly-used parameters are also shown on the Main tab. You can right-
click on the field in the Main tab to open a dialog box that allows you to change which 
parameters are shown on the Main tab.

3. To collect 4K points of data per line, set the following parameters in the Scan tab:

Note: You can use the mouse to adjust the value in many parameter fields. Click on 
the value and drag the mouse left to decrease the value or right to increase the 
value.

The Aspect ratio controls the X:Y ratio of the pixels in the displayed image. Since there is a 
8:1 ratio between 4096 samples/line and 512 lines using an Aspect ratio of 8 causes the pixels 
displayed in the image to be square. 

4. For TappingMode, use the following initial parameter settings in the Feedback tab:

5. For Contact mode, use the following initial parameter settings in the Feedback tab:

6. Click the Engage button in the Main tab or click the Engage icon. Scan lines appear in the 
Scan View once the tip engages and scanning begins.

7. Click the Scope button. Check to see whether the trace and retrace lines are tracking each 
other well. They should have a similar shape, but they may not overlap each other 
horizontally or vertically. Adjust the Scan rate, Integral gain, Proportional gain, and/or 
Setpoint (that is, Amplitude setpoint for TappingMode and Deflection setpoint for Contact 
Mode) parameters. Once the trace and retrace are tracking well, your tip is scanning the 
sample surface.

8. At this point, you may want to adjust the Scan size, X offset, Y offset, and Scan angle (Scan 
Tab) parameters to locate the scan over features of interest. If you increase the Scan size, 
remember that the Scan rate should be lowered.

Scan angle: 0.00 °

Scan rate: 2Hz

Samples/line: 4096

Lines: 512 (or 1024)

Aspect ratio: 8.00 (or 4.00 if Lines is 1024) and you want 
square pixels

SPM feedback: Amplitude

Integral gain: 0.2

Proportional gain: 0.3

Integral gain: 2.0

Proportional gain: 3.0

Deflection setpoint: 0V (vertical defection = -2V (before engage)
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Note: You can zoom in on the scan image by selecting the Zoom button below the 
image. Then, use your mouse to drag a box outline over the area you want to 
zoom in on. Click Offset to offset the center position of your scan.

9. With a 4K image, it may be useful to zoom in on the scan without changing the scan size. 
Select the Data Zoom button above the image. Use your mouse to drag a box outline on the 
image (begin by clicking where you want the center of the box to be). When you release the 
left button, you will be zoomed in (scan size of image display will change) but the scanner 
will remain scanning the original scan size. At this point you can choose to “pan” over to 
other areas of the total scan. Select the Pan button and click and hold the left mouse button as 
you move the mouse. The left arrow button above the image allows you to go back to the 
original scan and the right arrow button allows you to go to more zoomed in scans (if you 
have done multiple zooms). You may also choose to physically change the scan size or X/Y 
offsets by using the Zoom or Offset.

1.4.5 Capturing an Image

Once you have adjusted the scan parameters, you can capture a scanned image. Perform these steps 
once a scan you want to capture is in progress. 

1. You can capture a scan in any one of three ways:

• From the menu bar, select Realtime > Capture.

• On the Main Tab in the Scan View, click the Capture button. 

• Click the Capture icon in the toolbar.

The scan will continue. Notice that the status bar at the bottom of the NanoScope window (see 
Figure 1.4e) says Capture: On.  When the current scan is complete, the image will be stored 
automatically in the Capture Directory with the file name indicated in the status bar. The file 
name and directory can be changed by selecting Realtime > Capture Filename from the 
menu bar (see Figure 1.4f).

Figure 1.4e   Status Bar

Capture Status
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Figure 1.4f   Change Filename

2. In the Image Browser area (see Figure 1.4g), check to see if you are looking at the Capture 
Directory. If not, select the Capture Directory icon (or click the “...” button and select the 
Capture Directory, which is usually DI > Capture). If you don’t see the Image Browser, 
choose View > Browse.

Figure 1.4g   NanoScope Image View Window

3. Double-click the image you just captured. The image opens in the Image View window (see 
Figure 1.4g). Notice that the image filename and an image view are added to your 
workspace.

Image
Browse
Area

Image View
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4. If you need to change the Data Scale, use Format > Color Scale on the menu bar. or right-
click on the data scale value in the top right corner of the Image View window, and change 
the Data Scale value in the popup window. To change the Color Contrast, use Format > 
Color Scale on the menu bar to right-click on the thin color bar to the right of the image. If 
you need to change the Color Table, click and hold the color bar, then drag the mouse left or 
right.

Note: To rename image files, you can Save As, use Explorer to rename the file, or 
right-click on the image in the image browser and select Move.

Figure 1.4h   Color Scale

1.4.6 Analyzing an Image with the Section Analysis

After opening the captured image, you can analyze the image. In this example, the Flatten filter 
and Section analysis views are used.

1. Right-click on the name of the image in your workspace. Choose Add View > Flatten from 
the pop-up menu, select Analyze > Flatten from the menu bar, or click the Flatten icon.

The Flatten filter can be used to remove image artifacts due to vertical (Z) scanner drift, image 
bow, skips, and anything else that may have resulted in a vertical offset between scan lines. 
Refer to the Command Reference Manual, 004-122-000 for a detailed description of Flatten.

2. Set the input parameters for the filter. For example, you can choose the order of the 
polynomial to use to fit scan lines.

3. Click Execute.

4. If you want to modify the parameters used for flattening, click Reload. Then change the 
parameters and click Execute again.

5. Right-click on the name of the image in your workspace again. Choose Add View > Section 
from the pop-up menu, select Analyze > Section from the menu bar, or click the Section 
icon. Section analysis allows you to easily make depth, height, width, and angular 
measurements.
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6. Drag a line across the image. A vertical cross section along that line is shown in the upper 
graph area. The lower graph shows the power spectrum (Fourier Transform) of the cross 
section.

7. In the upper grid, drag the two cursors around to make measurements. You can grab two or 
more measurement cursors from the outside of the grid. You will see the cursor change from 
a  to a , at which point you can grab the measurement cursors. The results area at the 
bottom of the view shows various measurements at the marker position.

8. If you would like to make an Average Section, right-click on the image, select 

 

Rotating 
Box

 

. After drawing the box, you can make it rotate by holding down the shift key while 
grabbing anywhere in the box.

 

1.5 Using Online Help

 

The NanoScope software now includes complete documentation in online Help, including: Theory, 
Procedures and Interface references. 

If the help is not open, you must initialize the Help interface as follows:

• Select 

 

View

 

 > 

 

Help

 

 to open the Help window.

• Use 

 

Help

 

 > 

 

Nanoscope Help

 

 to display and hide the Help window.

To manually select the Help file:

1. Select 

 

Tools

 

 > 

 

Options

 

 > 

 

Set Help File

 

.

2. A browse dialog box appears to select the NanoScope 6 help file (see Figure 1.5a).

 

Figure 1.5a   

 

Initialize Help Dialog Box

3. Select the NanoScope6.chm file.

Browse to select
the NanoScope file
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4. Select View > Help to open the Help window.

1.5.1 Help Window

The Help window includes four tabs (see Figure 1.5b):

• Contents—Displays a list of topics and subtopics to search.

• Index—Allows searching by indexed items in alphabetical order.

• Search—Allows for searching the entire online help for a word or phrase.

Figure 1.5b   Help Window

Contents

The Contents tab allows for scrolling between main topics and subtopics. Click on a topic to view 
documentation in the right frame (see Figure 1.5b).

Index Tab

The Index tab allows to search the index of items, then select display to view the contents in the 
right frame (see Figure 1.5c).

Note: Often, the indexed item displays the top level help page where the item is 
found. For viewing the exact location, select the indexed item, display the page, 
then select the contents tab to view the related topic of the indexed item.

Menu Tabs

Right Frame

List of Topics 

for Viewing 
Contents
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Figure 1.5c   Index Tab

Search Tab

The Search tab allows to search the entire help text, then view the content in the right frame (see 
Figure 1.5d).

Figure 1.5d   Search Tab

Right Frame
for Viewing
Contents

Search
Index
Field
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1.6 Technical Support at Veeco

Your satisfaction and productivity regarding Veeco products and documentation are absolutely 
essential. 

1.6.1 Submitting Bug Reports

The NanoScope software automatically generates a bug report if the system should abort for any 
reason. This bug report form may help a Veeco programmer correctly analyze the problem that 
caused the abort. 

If the system should abort, the next time the software is initiated a bug report form automatically 
displays. For submitting bug reports, complete the following: 

1. Enter your name and a brief description of the functions in use when the crash occurred. 
Please describe the situation as accurately as possible.

Note: The form also includes crucial internal coding information for the developer.

2. Select Ok to transmit the file.

Note: A file labeled BUG.TXT will be created in your SPM directory. If another bug.txt 
file exists, the number on the file name is incremented or the information is 
appended to the previous file. 

Note: If there is no SPM directory or bug.txt file, the software prompts to place the 
file in another location. 

3. Once the file is created, attach the BUG.TXT file to an e-mail and send to bugs@di.com.

Note: You may not get a response to your bug submittal, but be assured that our 
programmers will analyze the problem and fix it in a future release if necessary.

1.6.2 Contact Information

Mailing Address

Technical Documents, Technical Support or Bug Reports at Veeco
Veeco Instruments Inc.
112 Robin Hill Rd.
Santa Barbara, CA 93117

E-mail: help@veeco.com
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Voice Phone

(805) 967-1400, (800) 873-9750

Fax

(805) 967-7717

E-Mail (Documentation Feedback only)

TechPubsSBO@veeco.com

World Wide Web

http://www.veeco.com
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Chapter 2   Realtime Views

The Realtime Views control the Realtime collection of data. Each part of the screen is an integral 
part of the scanning process. For more information on controlling views and the workspace, 
reference Chapter 1.

For general procedures in setting the parameters and data definitions, refer to the following 
sections:

• Overview of Realtime Views: Section 2.1

• Views for Scanning Section 2.2

• Tips on Using Realtime Section 2.3

• Force Curves Section 2.4

• Auto Panel Section 2.5

Note: If you have never used an AFM before, please refer to your microscope manual 
or contact Veeco for training.

2.1 Overview of Realtime Views

The Scan View includes all SPM parameters previously found in the Realtime control panels. The 
settings and parameters configure the microscope and NanoScope controller signals to optimize 
each scan. 

You can access Realtime views such as Scan-Single, Scan-Dual, Scan-Triple, Meter, Navigate, 
Video, and Point and Shoot by any of the following methods (see Figure 2.1a):

1. Right-click on Realtime in the workspace and select the desired view from the Add View 
menu.

2. Click on the desired view icon in the Realtime button bar.

3. Select a view from the Acquire menu.
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Figure 2.1a   Manual Scanning in Realtime

2.1.1 Typical Procedures to Begin to Scan

Set Scan parameters to affect piezo movement and data collection. The Scan functions control the 
type of scan to run, how large the scan is, its angle, scan rate, and number of samples per scan line. 
Prior to scanning a sample, the user must have knowledge of the following:

• Basic SPM processes

• Microscope safety, handling and tip/probe handling procedures (see your system 
manual)

• Sample handling procedures
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2.2 Views for Scanning

The general interface views associated with configuring parameters for scanning include:

• Navigate View Section 2.2.1

• Meter View Section 2.2.2

• Point and Shoot View Section 2.2.3

• Cantilever Tune Section 2.2.4

• Scan View Interface Section 2.2.5

• Scope Trace Plot Section 2.2.6

• Main Tab Interface Section 2.2.7

• Scan Tab Interface Section 2.2.8

• Channels Tab Interface Section 2.2.9

• Feedback Controls Tab Interface Section 2.2.10

• Other Tab Interface Section 2.2.11

2.2.1 Navigate View

Use the Navigate commands to locate the tip, focus on the surface, enable the trackball and move 
the stage. Use the Navigate View (previously the Realtime > Stage menu commands) to position 
the tip, locate a surface position for referencing Z height and move the stage for scanning the 
sample surface.

To access the Navigate View, click on the Navigate icon in the Realtime workspace. If the 
Navigate icon is not present, right-click Realtime in the workspace to view the functions menu. 
Select Add View > Navigate and the Navigate View appears in the client window.

Navigate Commands

The Navigate commands allow you to focus surface or locate the tip (see Figure 2.2a). To view the 
Navigate commands select Tools > Stage or the command icons for Focus Surface or Locate Tip. 
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Figure 2.2a   Navigate Menu Commands

Figure 2.2b   Navigate View
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Using the Navigate View

Access the Navigate View at any time when the stage movement or focus surface and locate tip 
settings are necessary.

Note: Some microscope options, such as Engage and Withdraw, are unavailable 
when the Navigate View is active. You must select another view, such as the 
Scan View, to enable these options.

1. Access Locate Tip and Focus Surface in the Navigate View or select the appropriate icons.

2. Select the Locate Tip button and focus on the tip using the trackball or arrow keys. When 
finished, click the Ok button.

3. For Focus Surface, use the trackball or arrow keys to move the stage in X, Y or Z directions.

Navigate View Parameters:

CAUTION: If Tip Focus is not accomplished before Focus Surface, there is a 
danger of crashing the tip during Engage.

XY Stage Motion Controls the horizontal, vertical and diagonal movement of 
the stage.

Speed Buttons allow for setting slow (S), medium (M) and fast 
(F) stage speeds by entering a speed value to the right of 
the buttons or using the scroll bar then select the S, M or F 
button.

Z Motion Up and down arrow keys control the height movement of 
the tip toward or away from the stage.

Auto Focus Opens an Auto Focus dialog box to set the Z axis focus 
from vision settings.

Trackball Enables or disables the X, Y stage and Z cantilever move-
ment by using the trackball.

Camera Controls the magnification used to view the stage or tip. 
Range: High Mag, Low Mag.

Illumination Sets the light intensity in the optics.

Zoom Changes the optical field of view (i.e., without stage or tip 
movement).

Vision System Displays the surface (in focus surface mode) or tip (in 
locate tip mode) and tip on the surface (in Realtime scan-
ning mode).
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SPM Parameters

To access the SPM Parameter controls, select Tools > Engage Settings > General or right-click in 
Navigate View and select Edit SPM Parameters (see Figure 2.2c). Parameter Controls are:

• Sample Clearance

• SPM Safety

• SPM Engage Step

• Load/Unload Height

Figure 2.2c   Edit SPM Parameters Dialog Box

2.2.2 Meter View

Access the Meter View (select Acquire > Meter) to view the photodetector signal, RMS 
amplitude, horizontal and vertical deflection signals, and the signal sum.

Meter View Interface

• Photodetector Signal—Corresponds to the positioning of the laser on the photodiode 
detector.

• Signal Sum—Sum of the voltage response from the laser in all 4 sections of the photo 
detector.

• Vertical Deflection—Corresponds to the voltage for vertical displacement of the laser 
signal. Should be “0” for centering.

• Horizontal Deflection—Corresponds to the voltage for the horizontal displacement of 
the laser signal. Should be “0” for centering.

• RMS Amplitude—Root mean square (RMS) signal measured at the detector 
(TappingMode only).
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Figure 2.2d   Meter View
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2.2.3 Point and Shoot View

The Point and Shoot View allows you to select specific points on an image (see Figure 2.2e). Use 
Point and Shoot to capture an image and/or collect a force curve for every point you designate. 

When you click a point on an image, a crosshair (+) marks the location. You can designate 
individual points, or use the tools in the Point and Shoot View to assign multiple points 
simultaneously. 

Figure 2.2e   Point and Shoot View

Controls and Parameters

Image/Scan Allows you to switch to Image/Scan mode. Use Image/
Scan mode to adjust scan parameters in any scan view.

Ramp/Force Curve Allows you to switch to Ramp/Force Curve mode. Use 
Ramp/Force Curve mode to adjust the ramp settings. You 
can select points on an image, ramp each point, and create 
a force curve for each point.

Image Channel Select the channel to use for the image.

Ramp Channel Select the channel to use for the ramp display.
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Capture Image and 
Ramp

Click this button to capture an image and save it in the 
Capture Directory, and to then capture a force curve at 
each designated point.

Capture Image Click this button to capture an image and save it in the 
Capture Directory. After the capture the software switches 
to Ramp/Force Curve mode.

Ramp Click this button to ramp a variable determined from the 
force curve menu at each point.

Capture Click this button to ramp each point, capture the ramp/
force curve, and save it in the Capture Directory.

Point Parameters Image Cursor Mode Settings:

Mark Only—Select points of interest on the image.

M/Ramp—Select points of interest. Software will auto-
matically ramp each point.

M/R/Capture—Select points of interest. Software will 
automatically ramp each point and capture a ramp/force 
curve.

Line Parameters Draw a line to select specific points on an image.

Point Number—Number of points in the line.

Spacing—The distance in nm between each point. All 
points are equidistant.

Clear Path—This button clears the current line and asso-
ciated points.

Convert to Points—Places a + in the location of each 
point in the line. The line disappears.

Box Parameters Draw a box in the area you want to place a group of points. 
You can use the parameters below to create a grid of 
points.

Row Number—Designates the number of rows of points 
in the grid.

Column Number—Designates the number of columns of 
points in the grid.

Row Space (nm)—Designates the distance in nm between 
each row of the box.

Col Space (nm)—Designates the distance in nm between 
each column of the box.

Clear Path—This button clears the current box and asso-
ciated points.

Convert to Points—Places a + in the location of each 
point in the grid. The box disappears.

Clear All Marks Removes all user-defined marks from the Point and Shoot 
image.

Save Marked List... Save the marks on the image as Path Files (*.psm).
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2.2.4 Cantilever Tune

The Cantilever Tune command allows determination of the cantilever resonant frequency and the 
setting of the operating point for TappingMode feedback (see Figure 2.2f). In addition, it is possible 
to determine the spring constant of a Contact Mode cantilever quickly and easily. Cantilever Tune 
sweeps the cantilever drive frequency over a selectable range, then displays a plot of the cantilever 
amplitude versus drive frequency on the Display Monitor. This command is enabled only when the 
Microscope mode parameter on the Other Controls panel is set to Tapping. On Small Sample 
MultiMode SPMs, verify that the switch located on the base is toggled to TM AFM before 
selecting the Cantilever Tune command. 

Note: The sweep channel is determined by the data selection in the Channel 1, 
Channel 2, or Channel 3 control panels.

Figure 2.2f shows how the maximum amplitude is attained in air at the cantilever natural resonance. 
Figure 2.2g shows the amplitude is reduced when it is in contact with the sample surface.

Figure 2.2f   Tapping Cantilever in Mid-air

Load Marked List... Opens and loads a previously saved Path File (*.psm) 
which contains marks on a Point and Shoot image. 
Note: If there are points on the image prior to selecting this 
option, when this button is selected the saved marks will 
appear in addition to the previous marks.

Laser

Cantilever
Resonant
Deflection 

Tapping Piezo

Photodiode
Detector
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Figure 2.2g   Tapping Cantilever on Sample Surface

In TappingMode, the optical lever technique reflects a laser beam off the back of the oscillating 
cantilever, thence to a segmented photodiode. The differential signal between the top and bottom 
photodiode segments provides a sensitive measure of cantilever deflection. As the sample is 
scanned, analog circuitry determines the RMS value of the rapidly changing cantilever deflection 
signal. The RMS value of the cantilever deflection signal corresponds to the amplitude of the 
cantilever oscillation. Changes in amplitude of the cantilever oscillation is controlled by the 
feedback system to track the sample surface.

Access the Cantilever Tune dialog box by selecting the Tune icon or by selecting 
Tune... from the Realtime menu.

Photodiode
Detector

Laser

Cantilever
Resonant
Deflection 

Tapping Piezo
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Figure 2.2h   Cantilever Tune Dialog Box

Select Cantilever Tune Dialog Box Definitions:

Mode box Toggles the Auto Tune signal from the main to interleave sig-
nals.

Settings:

Main— Displays the set of parameters applied to the main scan 
(see Section 2.2.7).

Interleave—Displays a duplicate set of parameters applied 
only to the interleaved portions of the scan.

Auto Tune Button Executes the automatic tuning procedure: the cantilever is 
excited through a range of frequencies beginning at the Start 
frequency and ending at the End frequency.

Auto Tune
Button

Mode Box

Auto Tune
Parameters
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Auto Tune Parameters:

2.2.5 Scan View Interface

The Scan View display includes an image viewer, color bar, scope viewer, vision control viewer 
(for systems configured with vision controls), and numerous parameters to configure Realtime data 
collection. Most SPM operators use only a few of these parameters to obtain images. The 
parameters within each tab are also microscope-specific or level-access dependent and may be 
greyed out or hidden, depending on microscope configuration.

Scan View Interface:

Start Frequency Starting point of the Auto Tune frequency sweep.

End Frequency Ending point of the Auto Tune frequency sweep.

Target Amplitude Targeted output signal amplitude at the photodiode detector. This value 
should not be confused with Drive amplitude, which is the amplitude applied 
directly to the cantilever itself (see Drive amplitude).

Range and Settings: 0.00 to 8.00 V

Note: Dimension Series SPMs, nominal = 2.00V
          Small Sample MultiMode SPMs, nominal = 3.00V

Peak Offset Percentage of cantilever’s free-air resonant frequency to be automatically off-
set. Peak offset is used to compensate for changes in resonance before 
engagement due to the tip’s interaction with the surface after engagement.

Range and Settings: 0 to 50%; typical value = 1 to 2%

Minimum Q Q is the value defined by the amount of oscillation it takes for a wave to drop 
to 1/e (e = 2.718) of its amplitude value (i.e. a wave with an amplitude of ten 
would have a Q of 10/e, or 3.6788). Minimum Q establishes a minimum 
“width of peak” value allowed by the AutoTune function. Peaks not meeting 
the Minimum Q may be ignored by setting the Smash Q factor.

Smash Width Factor The width of the area beneath the wave smashed (set to zero) when a peak not 
meeting the Minimum Q requirement is found. 
Note: This parameter does not appear if Minimum Q is 0.

Image Window During scanning, the Realtime image of the sample appears along with a cur-
sor. The cursor moves along the image vertically to show the engaged tip posi-
tion on the surface. The Measure button allows you to make line 
measurements. The Data Zoom button allows you to “zoom in” to a smaller 
view, but doesn’t change the scan size. The Pan button allows you to pan over 
to other areas of the total scan if you are zoomed in.

Color Bar Sets the color table for viewing height data in the image window. Left-click 
on the color bar and drag the mouse left or right.

Image Parameters Configure options below the image window to select the channel and image 
display values, (e.g. Data type, Line direction, Data scale, and so on).
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Figure 2.2i   Scan View and Main Controls

User-Defined Parameters in the Scan View

Clicking on a parameter and then dragging the mouse back and forth increases or decreases a 
parameter value much like an old analog slider. The significance, range of acceptable values, and 
specific information about control panel parameters are discussed in this section.

Parameters listed in the Scan tabs depend on the microscope selected and the Show All Items 
function (right-click on tab interface > Show All). Parameters necessary for one style of 
microscope are not applicable to another. For example, the Drive frequency and Drive Amplitude 
parameters are enabled on the Feedback tab only when the mode is set to TappingMode.

Some users find operating an SPM less confusing if the number of parameters is limited to only the 
most essential ones. For this reason, The Main tab in the Scan View contains user specified 
parameters.

Vision Window The Vision window displays the Optics or Scope data. Select the Video or 
Scope or Line Plot button.
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2.2.6 Scope Trace Plot

Select the Scope button in Scan View (see Figure 2.2i) for a scope to display a plot versus the probe 
position in an oscilloscope-type format on the image display (see Figure 2.2j).

Figure 2.2j   Scope Grid

Scope Trace Interface

By right-clicking the Scope grid, you will get a menu of different options (see Figure 2.2k).
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Figure 2.2k   Scope Grid Parameters

 These menu options allow you to make the following changes:

Color Allows operator to change color of:

• Curve (data)

• Text

• Background

• Grid

• Minor Grid

• Markers

Filter Typically used for a Profiler Scan.

• Type—Allows the user to plot the mean, maximum or 
minimum y-value per x-value.

• Points—Allows user to plot multiple vertical axis (y-)values 
at each horizontal axis (x-)value. Select 4K, 8K, 16K or 32K 
Points to limit the display to 4, 8, 16 or 32 times 1024 points.

Minor Grid Places a minor grid in the background of the Vision Window.

Scale Allows user to auto scale, set a curve mean, or set their own data range.

Y Translate Offsets the curve by placement of vertical cursor on the grid. Grab vertical 
cursor in the black space above the grid and pull down onto grid.

Line Style For each curve, operator can choose, connect, fill down, or point.
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User Preferences Restore—Reverts to initial software settings

Save—Saves all changes operator has made during this session. This 
becomes the new default settings.

Copy Clipboard Copies the grid image to the Microsoft Clipboard.

Print Prints out the current screen view to a physical printer.

Export Exports data in bitmap, JPEG or XZ data format.

Active Curve Determines which curve you are analyzing.



Realtime Views
Views for Scanning

56 Nanoscope Software 6.12 User Guide Rev. C

2.2.7 Main Tab Interface

 Figure 2.2l shows an example of parameter controls and settings for scanning in TappingMode.

Figure 2.2l   Main Controls Panel

Engage Button The Engage command brings the tip into contact with the sample surface and 
starts the Realtime imaging process.

Withdraw Button The Withdraw command stops the scanning process and withdraws the tip 
from the surface.

Frame Down Button The Down command restarts the Realtime scan at the top of the frame. This 

allows you to go directly to the start of the frame and not have to wait for the 
previous frame to end.

Frame Up Button The Up command restarts the Realtime scan at the bottom of the frame. It is 

an easy way to begin a view an entire Realtime frame from the bottom. By 
clicking on this icon, the Realtime scan restarts and moves up at the bottom of 
the frame. This allows you to go directly to the start of the frame and not have 
to wait for the previous frame to end.

Capture Button The Capture command stores the image data of the current scan. During the 
image scanning process, the cursor moves up and down a square image frame. 
When the cursor moves up or down one complete frame the Capture is com-
plete and an image file is saved.

Capture Cancel Button The Capture Cancel command stops the capture process.
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Procedures to Set the Main Tab

The parameters in the Main Control panel (see Figure 2.2m) are unique to your specific needs. 
Configure specific parameters as follows:

1. Right-click in the Main Control panel.

2. In the Parameter list, verify each Scan View tab name.

3. Expand the desired tab name by clicking on the plus (+) sign next to each name (i.e., Scan, 
Feedback, Interleave, etc.) to view a list of parameters.

4. Highlight the desired parameters for viewing on the Main Controls tab.

Note: Only eight parameters may be selected. Therefore, take note of the most used 
parameters to view in the Main Controls tab.

5. With the parameter selected, click the double arrows (<<) to position the selected parameter.

6. Repeat Step 2 - Step 5 for displaying eight main controls parameters for viewing during the 
scanning process.

Select Ok to accept the changes or Cancel to revert to the previous view.

Figure 2.2m   Select Scan View Controls
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2.2.8 Scan Tab Interface

The Scan tab (see Figure 2.2n) includes parameters influencing piezo movement and data 
acquisition, as well as the ability to execute non-square scans. This Tab panel is probably the most 
frequently used panel, as it controls what type of scan to run, how large the scan is, its angle, scan 
rate, and number of samples per scan line.

Figure 2.2n   Scan Tab Parameters

Scan Tab Parameters

Scan size Determines the size of the scan by controlling the voltage applied to the 
X and Y piezos.

Range or Settings:

• 0 to 440V

• 0 to XXµm (scanner-dependent)

The units of this parameter are volts if the Units parameter (Other Con-
trols panel) is set to Volts. The units are linear distance (nm or µm) if 
the Units parameter is set to Metric.

See also, Optimizing the Scan Size Parameter on page 85.

Aspect ratio Controls the width-to-height size ratio of scans. Set Aspect ratio to 1.00 
for square scans. An Aspect ratio of 2.00 yields scanned images having 
width equal to twice the height. 

Range or Settings: (depends upon the number of scan lines) 1 to 256.
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Figure 2.2o   Aspect Ratio Example

Figure 2.2p   Scan Angle Rotated Example.

X offset, Y offset Controls the center position of the scan in the X and Y directions, 
respectively.

Range or Settings: ±220V; ± XXµm (dependent on Scan size and 
scanner).

See also, Optimizing the X Offset, Y Offset Parameter on page 85.

Scan angle Controls the angle of the X (fast) scan relative to the sample.

Range or Settings: 0 to 359° (Any angular value can be entered with 
the keyboard)

Changing this parameter can dramatically affect the quality of 
images due to tip effects (tip side wall angle).

Setting this parameter to a setting besides 0 or 90° may reduce the 
maximum allowable Scan size 10-20 percent due to corner con-
straints (see Figure 2.2p).

Scan rate The Scan rate sets the number of fast scan lines performed per sec-
ond. When the Scan rates are low, it can take a fairly long time to 
scan an entire frame. For example, With the Scan rate set to 0.5Hz 
and the Number of samples set to 512, it can take over 17 minutes 
to capture a single image.

Range or Settings: 0.1-237Hz, depending on the number of 
Samples/line.

See also, Optimizing the Scan Size and Scan Rate Parameters on page 85.

1.00

4.00

8.00

16.00
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Table 2.2a   File Size/Samples per line

Note: Samples/line should be kept at 512 or higher for high resolution scans. To 
increase the frame rate (rate at which complete images are generated), the 
Lines parameter should be reduced. When the Lines parameter is reduced, file 
sizes in Table 2.2a are reduced accordingly.

Note: Disabling the Slow scan axis and viewing the Scope Mode display is a 
convenient way of setting the Feedback Gain parameters. 

Lines Selects the number of lines to scan in a frame. The Lines parameter 
reduces resolution along the Y axis. It also speeds imaging (or frame 
rate) and reduces the size of the resulting image file. 

Range or Settings: 2 to 1024. The maximum number of lines may be 
limited by the value for Samples/line.

Tip velocity Velocity of the tip (in µm/s) as it scans over the surface.

When Tip Velocity is changed, the Scan Rate adjusts automatically.

Samples/line Selects the number of sample data points per scan line.

When this parameter is changes, the number of scan lines per image 
(Lines) are automatically adjusted to maintain the same ratio 
between the samples/line and lines per image.

Range or Settings: 128 to 16384. This setting influences the memory 
size of captured files and image resolution (see Table 2.2a).

Samples/line value
File size (for square 
scans, including 8K 

header)

128 40Kb

256 136Kb

512 520Kb

Slow scan axis Allows the slow scan to be disabled, causing the fast scan to be 
repeated continuously at the same position. This means that the image 
displays the same line continuously. Images may be presented either as 
“true” X-Y renderings of the sample surface (Enabled), or as 
“stretched” single-line scans of length equal to the Scan size (Dis-
abled).

Range or Settings:

• Enabled—Sample is scanned in the slow scan 
direction. (This is the normal setting of this parameter.)

• Disabled—No scanning of the sample in the slow 
direction is performed. The fast scan is repeated at the 
same position.
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The advantage of using the Slow Scan Axis > Disabled parameter is to emphasize one area (line) to 
adjust SPM parameters. For example, an area of the image appears fuzzy (believing SPM 
parameters are not optimized for the sample). Disable the Slow Scan Axis, view the image in 
Scope mode, and reconfigure scan parameters to optimize the scan. 

Note: Setting the Slow scan axis parameter to Disable stops the slow scanning of the 
piezo, but does not stop the movement of the Realtime display in Y. Lines are 
replicated in the Y direction.

2.2.9 Channels Tab Interface

The Channels tab (see Figure 2.2q) consists of parameters for three channels. Each channel 
represents a unique scanning image. Up to three data Channels may be opened by selecting each 
channel and choosing a data type to view simultaneously, opening up Realtime 3 times. Channels 
are numbered 1, 2 and 3 and feature their own control panels. When a Data type is selected on a 
Channel, its image appears on the Display Monitor. It is possible to have up to three separate 
images from each scan. For example, a TappingMode scan might simultaneously present a Height 
image on Channel 1, a Deflection image on Channel 2, and an Amplitude image on Channel 3. 

Parameters shown on each Channel control panel vary slightly, depending upon the type of 
microscope selected and its operating mode. 

Figure 2.2q   Channels Tab
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Channel Tab Parameters

Data Type Range or Settings 

Data Type Settings vary, depending upon the microscope selected and operating mode 
as shown in the field descriptions below. The Data type parameter may 
receive: no data (Off); sample-height data (Height); cantilever oscillation 
amplitude data for TappingMode (Amplitude); cantilever deflection data 
(Deflection); STM current data (Current); phase data (Phase).

     See also, Optimizing the Data Type Parameters on page 86.

Amplitude (TappingMode 
and Force Mode only)

The RMS of the cantilever amplitude signal is displayed and captured.

Current (STM only) Data displayed and captured is the tunneling current generated by the pream-
plifier. (When set to Current, the units of the data are nA.)

TM Deflection Cantilever deflection signal data is displayed and captured. (When set to TM 
Deflection, the units of the data are in distance or volts.)

Height The Z piezo voltage set by the feedback calculation in the Digital Signal Pro-
cessor (DSP) is displayed. (The displayed data comes from the voltage output 
to the Z piezo.) Units are distance (e.g., nm, µm, etc.). Standard imaging of 
topography.

Off Channel is turned off.

Phase (MFM, EFM) Phase data from oscillating TappingMode tips, generally used with Magnetic 
Force Microscopy (MFM) and Electrical Force Microscopy (EFM), is dis-
played and captured. This setting appears when the microscope is configured 
with an Extender™ Electronics Module.

Potential (EFM) Surface potential data is displayed. (For detailed information on Surface 
Potential or EFM features, see Support Note 231, Electric Force Microscopy 
on the MultiMode Systems.)

Thermal Temperature data from thermal tips is displayed and captured. 

Deflection Cantilever deflection signal data is displayed

Friction Torsional deflection signal data is displayed
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Data scale The Data Scale controls the Z scale corresponding to the full height of the dis-
play and color bar.

Range or Settings:

• 0.0067 to 440V (Data type set to height, Units are set to 
volts).

• XX to XXX µm (Scanner dependent; where Data type is set to 
height, Units set to metric).

• XX to XXX µm (Sensitivity dependent; where the Data type 
is set to deflection or amplitude; Units are set to metric).

• 0.00003815 to 2.5V or 20V (Data type set to amplitude; Units 
set to volts or deflection)

• 0.0031 to 200nA (Data type set to current; Units are set to 
metric).

• 0.0003052V to 20V (Data type set to current; Units are set to 
volts).

See also, Optimizing the Data Scale Parameters on page 86.

Data center Offsets centerline on the color scale by the amount entered.

The Data Center offset does not become a permanent part of the data.

Range or Settings: 

• ± 220V

• ± TappingMode

Line direction Selects the direction of the fast scan data collection that is displayed in the 
image.

The feedback calculation is always performed regardless of the scan direction. 
This parameter simply selects whether the data is collected on the trace or the 
retrace. This parameter selects the relative motion of the tip to the sample.

Range or Settings:

• Trace—Data is collected when the relative motion of the tip is 
left to right as viewed from the front of the microscope.

• Retrace—Data is collected when the relative tip motion is 
right to left as viewed from the front of the microscope.

Scan line The scan line controls whether data from the Main or Interleave scan line is 
displayed and captured. 

Range or Settings: Main or Interleave

This parameter is not selectable when the Interleave mode parameter is set to Disable. The system is locked 
on the Main scan lines whenever the interleaved mode is turned off.



Realtime Views
Views for Scanning

64 Nanoscope Software 6.12 User Guide Rev. C

2.2.10 Feedback Controls Tab Interface

The Feedback Controls parameters allow for monitoring the signals between the NanoScope 
Controller and the cantilever. These signals adjust the setpoint, oscillation frequency, drive 
voltage, Z response for surface tracking, and output voltages. The purpose of the Feedback 
Controls is to maintain a constant setpoint (deflection, amplitude, or current) in the Feedback 
Loop for tip/sample control and tracking optimization.

Figure 2.2r   Feedback Controls Tab in TappingMode

Realtime Planefit Applies a software leveling plane to each Realtime image, removing up to first-
order tilt. Three types of planefit are available to each Realtime image.

Range or Settings:

• None—Only raw, unprocessed data is displayed.

• Offset—Takes the Z-axis average of each scan line, then subtracts 
it from every data point in that scan line.

• Line—Takes the slope and Z-axis average of each scan line and 
subtracts it from each data point in that scan line. This is the 
default mode of operation, and should be used unless there is a 
specific reason to do otherwise.

 Offline Planefit Applies a software “leveling plane” to each captured image for removing up to 
first-order tilt. Three types of planefit are available to each Offline image.

Range or Settings:

• None—Only raw, unprocessed data is displayed.

• Offset—Captured images have a DC 21 offset removed, but they 
are not fitted to a plane.

• Full—A best-fit plane which is derived from the data file 
subtracted from the captured image.

See also, Optimizing the Offline Planefit Parameter on page 86.
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Feedback Control Parameters

Z Modulation (Fluid TappingMode 
only)

Allows the user to add the drive oscillation signal to the Z piezo 
voltage. This parameter is used to set up fluid cell oscillation in 
any Dimension system for Fluid TappingMode.

Range or Settings:

• Enabled—Enables Z modulation. Drive 
oscillation signal (Drive Frequency) is added to Z 
piezo voltage. When enabled, the Z limit must 
be set ≤ 420V.

• 0—Disables the Z modulation (i.e., no additional 
signal is added to Z piezo voltage).

The desired Drive amplitude and Drive frequency voltages 
(Realtime > View > Sweep > Cantilever Tune) need to be set 
for Fluid TappingMode operation.

SPM feedback Selects the signal to be used for tip feedback according to the 
selected Microscope mode parameter (Other Controls panel). 
For Contact AFM, the choice defaults to Deflection; however, for 
TappingMode, you may select either the Deflection or the 
Amplitude. STM offers three choices of feedback: Linear, Log 
and Boost.

Range or Settings:

• TappingMode—Amplitude, TM Deflection- 
Phase (Forcemod only)

• Contact Mode—Deflection only

• STM—Linear, Log, Boost

   Linear—The linear difference between the instantaneous tun-
neling current and the Setpoint current is used in the feedback 
calculation.

   Log—The difference between the log of the instantaneous tun-
neling current and the log of the Setpoint current is used in the 
feedback calculation.

   Boost—Optimizes the feedback performance for high Scan 
rates over rough surfaces. This is not intended for atomic images. 

     See also, Optimizing the STM Feedback Parameters on page 87.

Input Feedback Controls Frequency Modulation (MFM or EFM) and Surface 
Potential.

Integral Gain Controls the amount of integrated error signal used in the feed-
back calculation.

Range or Settings: 0 to 1024
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Table 2.2b    Typical Integral Gain Ranges:

     See also, Optimizing the Integral and Proportional Gain on page 87.

Gain settings vary, depending upon the scanner used, the sample and scanner sensitivity. See Table 2.2b for 
approximate, nominal values (assumes a Scan rate of ≈ 2.5Hz).

Scanner Contact AFM and 
Forcemod TappingMode STM

Aa

a. For atomic-scale images, scan rate must be increased to approximately 
60 Hz.

1.0 - 8.0 0.2 - 1.0 0.3 - 5.0

Proportional Gain Controls the amount of the proportional error signal used in the 
feedback calculation. The Proportional gain term in the feed-
back calculation has equal gain at all frequencies; therefore, it 
has a dominating effect over the Integral gain for high frequen-
cies (scan rates).

Range or Settings: 0 to 1024

(Typical settings for the Proportional gain parameter are 35-
100% more than Integral gain values).

LookAhead Gain Adjusts Z-axis tracking of the sample surface by “remembering” 
previous scan line data, then anticipating adjacent surface fea-
tures on the current scan line. Look ahead gain is a valuable 
assist to the Integral gain parameter when scanning regular, steep 
features such as gratings and integrated circuits (e.g., by decreas-
ing tip overshooting, etc.).

Range or Settings: 0 to 1

    See also, Optimizing the Look Ahead Gain Parameter on page 87.

Setpoint The meaning of this parameter depends on the operating mode of 
the microscope as follows:

Amplitude Setpoint (TappingMode)—defines the amplitude of 
the cantilever oscillation signal to be maintained by the feedback 
loop. (Range: 0.00 to 10.00V)

Deflection Setpoint (Contact Mode)—Controls the deflection-
signal level used as the constant desired voltage in the feedback 
loop. (Range: 10.00 to 10.00 V)

Current Setpoint (STM)—Controls the constant current main-
tained by the feedback loop. (Range: 0.0 to 100.0nA)
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Drive frequency (TappingMode and 
Force Mode only)

Selects the oscillation frequency applied to the piezoelectric 
crystal that vibrates the cantilever.

Range or Settings: 0.00 to 250MHz

The Center frequency is adjusted with the Cantilever Tune 
command to find the resonance frequency of the cantilever. The 
maximum cantilever oscillation amplitude occurs at its resonant 
frequency. The software sets the Drive frequency equal to the 
current Center frequency value when the Ok button in the Can-
tilever Tune control panel is pressed.

Drive Phase (TappingMode and Force 
Mode only)

Selects the phase of the drive voltage applied to the piezoelectric 
crystal that vibrates the cantilever.

Drive amplitude (TappingMode and 
Force Mode only)

Selects the amplitude of the drive voltage applied to the piezo-
electric crystal that vibrates the cantilever.

Range or Settings: 0.00 to 20.00V

The Drive amplitude is also adjusted with the Cantilever Tune 
command. Increasing the Drive amplitude increases the cantile-
ver-oscillation amplitude. The cantilever-oscillation amplitude is 
increased to an appropriate level with the Cantilever Tune com-
mand. In AutoTune, the Drive Amplitude automatically adjusts 
to get a cantilever oscillation (rms amplitude) equivalent to the 
user’s Target amplitude.

Bias Controls the sign and magnitude of the bias voltage applied to 
the sample.

Range or Settings: -10.00 to 10.00V

When used with STM, typical settings for the Bias voltage 
parameter are 20 to 100mV for conductive samples and up to 
several volts with poorly conducting samples. Positive settings of 
the Bias voltage item correspond to negative current (electrons) 
tunneling from the tip into the sample on heads with the Bias 
applied to the Sample or Tip.

Analog 1, 3, 4 This voltage has no effect on the operation of the standard micro-
scope, but is useful in custom applications.

Range or Settings: -10.00 to 10.00V. These settings are only 
displayed with either NSIV or NSIIIA with Quadrex 
extender.

Aux Lockin Directs an external input signal through the auxiliary lock-in 
amplifier.

Drive Phase The phase of the AC bias signal applied to stimulate piezore-
sponse.

Lockin BW The bandwidth of the effective bandpass filter centered on the 
TTL level reference frequency (i.e., the cantilever drive fre-
quency in the NSIV Controller) used by the main lock-in ampli-
fier.
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InterSave Parameters Range or Settings

Several parameters (e.g. Z modulation, SPM Feedback, etc.) are highlighted by dark gray or green 
background. Dark grey indicates that the parameters are coupled with the equivalent values in the 
Feedback controls. By selecting (left-click) the Interleave parameters, the grey field turns green, 
indicating that the Feedback and Interleave parameters are decoupled and the value in those 
parameters will be used as feedback during the interleave scan line.

Interleave Mode

• Interleave—Adds a second, interleaved set of lines to the scan, which can be accessed 
from the Channel panel and captured as data. Invoking Interleave reduces the slow axis 
speed by one-half and doubles the capture time.

• Lift—A variant of Interleave, the Lift option uses the first set of scan lines to detect the 
surface, then lifts the probe above the sample surface on the interleaved set of scan lines 
according to the Lift start height and Lift scan height parameter settings. During the 
Interleaved scan, the tip mimics the surface topography from the previous surface scan 
line (see Figure 2.2s). 

Figure 2.2s   Interleave Lift Mode

• Linear—Lifts the tip to a predetermined height and runs the interleave scan at that 
height. 

• Disabled—Turns off the interleave scanning.

• Retrace Lift—Lifts after the trace scan in the retrace direction. This parameter is 
optimized with the Rounding parameter (Microscope > Calibrate > Scanner > 
Rounding). The suggested rounding setting is 0.2.
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Figure 2.2t   Retrace Lift Mode

Figure 2.2u   Lift Scan Height Illustrated

Lift scan height Specifies the tip’s height above the sample surface during interleaved scans. 
This parameter is in effect ONLY when the Interleave mode parameter is set 
to Lift, Linear, and Retrace Lift (see Figure 2.2u).

Range or Settings: XXµm (Scanner dependent)

The maximum meaningful value of the parameter depends on the Z voltages 
applied in the Main scan line and the maximum voltage that the system can 
output. The maximum voltage that can be applied to the piezo is ±220V. It 
will be lower if the Z voltage is restricted by the Z limit parameter.

Lift start height Specifies the height that the tip is to be lifted above the sample surface at the 
start of each interleaved scan. Generally, this parameter serves to lift the tip 
clear of any contamination layers present on the sample before assuming its 
Lift scan height during interleaved scans. This parameter is in effect ONLY 
when the Interleaved mode parameter is set to Lift and Retrace Lift. This 
parameter defines an offset from the Z voltage, or height, applied to the piezo 
on the Main scan line.

Range or Settings: XXµm (Scanner dependent)
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Figure 2.2v   Lift Start Height Illustrated

Tips for Using the Lift Start Height Parameter

• This value can be left at zero for TappingMode and STM. It is generally only used for 
Contact AFM to break the tip free of the adhesive force produced by the water layer 
before settling to the final tip height.

• The maximum meaningful value of the parameter depends on the Z voltages applied in 
the Main scan line and the maximum voltage that the system can output. The maximum 
voltage that can be applied to the piezo is ±220V. It will be lower if the Z voltage is 
restricted by the Z limit parameter.

The tip will go through this height at the start of every lifted scan line, then proceeds to the lift scan 
height for the rest of the scan line. 

Drive Feedback Controls

The Drive Feedback Controls contain parameters for precisely maintaining feedback levels 
during TappingMode imaging. This protects tips and samples, and assists greatly in maintaining tip 
engagement. Many users are familiar with the difficulties of minimizing tip-sample forces on 
extreme surfaces (i.e., surfaces which are extremely hard or soft). Very hard surfaces tend to wear 
out silicon tips rapidly; very soft samples are easily damaged by the tips themselves. Minimizing 
tip-sample forces in TappingMode with a higher setpoint may also lead to a condition in which tips 
suddenly disengage from surfaces. 

Refer to the following sections on the Drive Feedback interface:

• Theory on page 71

• Parameters in Drive Feedback: on page 71
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Theory

When enabled, Drive Feedback works by readjusting the drive amplitude at the beginning and end 
of each scan line. As the tip reaches either edge of the scan area, the tip is lifted off the surface by 
the Drive height amount and the drive amplitude is adjusted by a factor equal to the Drive gain 
times the drive error signal. This occurs for a duration of Drive time. The tip then turns around, 
descends to the surface, and resumes scanning.

Use Drive feedback parameters only for TappingMode imaging and Disable during other types of 
imaging. Although automatic control of Drive Feedback is not required for most TappingMode 
imaging, it should be applied whenever imaging extreme surfaces and when making tip changes 
with Automatic tip exchange.

Parameters in Drive Feedback:

Drive height Distance tip is lifted during readjustment of drive feedback. Default is 

5.00nm. Maximum values are .

Drive time Time required for the tip to exit the scan boundary, turn off feedback, ascend 
to the Drive height and adjust drive feedback. 

Default: 10.00ms

Maximum Drive Time: 100ms

Drive setpoint Drive amplitude setpoint, expressed as a fraction of the free-air amplitude. 

Default: 0.90

Range: 0.5 to 2.0

Drive gain Integral gain applied to the feedback loop’s drive error signal. Once the tip 
resumes normal scan height, Drive gain is no longer applied. Default is 1.00. 
Range: -1024 to 1024

Drive feedback The Drive feedback parameter turns drive feedback parameters on and off. 
Enabled is on, Disabled is off.

ZLimit
2

----------------±
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2.2.11 Other Tab Interface

The Other Controls parameters set the type of microscopy, Z tracking limits, units to use in 
measuring and other parameters specific the to microscope mode (i.e., the parameters that appear in 
the Other Controls panel will vary from one microscope to another). In the Workspace menu, 
select R001 Time. In the Realtime Scan window, select the Other tab.

Figure 2.2w   Other Tab

Parameters in the Other Controls Tab:

Microscope mode Selects the type of microscopy to be employed. Switching this parameter 
enables/disables other parameters. Also, on MultiMode SPMs, any change 
to the Microscope mode must be accompanied by use of the mode selector 
switch on the microscope’s base.

Range or Settings:

Contact, Tapping or STM

Z limit Permits attenuation of maximum allowable Z voltage and vertical scan range 
for achieving higher resolution (smaller quantization) in the Z direction.

Range or Settings:

11 to 440V (with Units set to Volts)

FM igain Integral gain for Frequency modulation. Controls the feedback loop that uses 
phase electronics.

FM pgain Proportional gain for Frequency modulation. Controls the feedback loop that 
uses phase electronics.
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Deflection Limit Use this parameter for attenuating the input voltage signal (appears only 
when performing Contact AFM). 

Range or Settings:

•  2.500V to 20.0V for regular imaging

•  20.00V in Force Mode only

Amplitude Limit Use this parameter for attenuating the input voltage signal (appears only for 
TappingMode or STM).

Range or Settings:

• 2.500V for regular imaging

• 20.00V in Force Mode only

Illumination Controls the fiber optic illumination of the sample in Dimension series 
microscopes.

Range or Settings: 0 to 100, recommended range is 20 to 50

Units Selects whether the units of certain scan parameters are in Volts or in units of 
Metric distance (nm, etc.). Parameters affected include Scan size, X Offset, 
Lift start height and Lift scan height, Y Offset, Data Scale, Z Limit, Z Scan 
Start, Ramp Size, Column Step and Row Step.

Range or Settings:

• Volts—Parameters are in Volts.

• Metric—Parameters are in units of distance (nm, µm, etc.) 
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Engage Setpoint (Tap-
pingMode only)

Allows the user to correct for loss of tracking on engage due to sample dif-
ferences. The automatic Engage procedure establishes the setpoint voltage at 
the smallest possible value that detects the sample surface, resulting in a 
value that protects both the sample surface and the cantilever tip. However, 
this value may not be sufficient for optimal surface tracking on all samples. 
The setpoint voltage determined by the automatic Engage procedure will be 
multiplied by the Engage Setpoint value, increasing or decreasing tapping 
force.

Range or Settings: 

0.5 through 2.0. A value of 1.0 results in no change to the tapping force. Val-
ues less than 1.0 increase the tapping force and values greater than 1.0 
decrease the tapping force. A value of 0.9 is nominal for most samples.

Example of Engage Setpoint

The Engage Setpoint for a particular sample may be empirically deter-
mined. Procedures are as follows:

1. Set the Engage Setpoint to 1.0 and engage on the sample. 

2. After engagement, make note of the Setpoint parameter. 

3. While watching the scan, adjust the Setpoint value until the tip 
tracks the surface correctly. Calculate the following: 

- Setpoint value/ Starting Setpoint value = Engage Setpoint 
(For optimal value, take the average of several engages on a selec-
tion of samples or different areas of the same sample).

Bidirectional scan When the Bidirectional scan parameter is Enabled, data from both Trace and 
Retrace scans are used to capture frames in half the normal time. Images 
have alternately shifted lines, which cause features to lose some of their lat-
eral definition; however, data may be used for metrological analysis. Use to 
save time while capturing images.

Range or Settings: 

Enabled or Disabled

When Enabled, features shown in images lose some lateral definition, mak-
ing point-to-point measurements inadvisable. Vertical data, however, is unaf-
fected.

Use the Scan line shift parameter to readjust images with the Bidirectional 
scan parameter Enabled. This will shift scan lines relative to one another to 
restore some lateral definition in features.

Scan line shift Use the Scan Line Shift parameter to shift trace and retrace lines relative to 
one another by up to 5 pixels in either direction. Units are in pixels and range 
from -5 to +5. Scan line shift is used for readjusting images captured when 
the Bidirectional scan parameter is Enabled.

Range or Settings: -5 to +5

This parameter is generally only for images that have been captured with the 
Bidirectional scan parameter set to Enabled.

Tip Serial Number Saves input in the image header (Ciao Scan List) for users who keep a tip fil-
ing system. This is to keep track of the tips used for certain images. 

Serial Number: Scanner Calibration file.
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Min. Engage Gain 
(STM only)

Allows user to engage tip in constant height mode. In constant height mode, 
the gains (feedback) is disabled. However, the Min. Engage Gain parameter 
provides for gain during engagement.

Strip Chart Rate Frequency of (Z-position, deflection) data point acquisition.

Range: 32kHz

Typical value: 1kHz

Strip Chart Size Time interval over which (Z-position, deflection) data points are displayed.

Typical value: Tens of seconds.

Note: Although the strip chart collects and displays data over the time inter-
val defined by clicking Start, then later, Stop, this data is not saved for sub-
sequent use until the Capture icon is clicked. If Capture is clicked while 
strip chart data is being taken, what is saved begins at the start of the chart 
(sooner than the icon is clicked).
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Auto Gain

Auto Gain automatically sets the feedback parameters (Proportional and Integral gain) for a 
given sample. 

Auto Gain works by analyzing the difference between Trace minus Retrace (TMR). The analysis 
is used to choose a set of feedback parameters that minimizes the TMR value. By specifying the 
starting value of the Integral gain sweep, the ending value, and the size of the increments, Auto 
Gain may be used to calculate a set of useful feedback parameters.

For the purposes of this analysis, Proportional gain operates as a factor of Integral gain. The 
relationship is , where F is a factor defined as Pro. Gain factor. 

Auto Gain only requires the input of the three Gain values in order to calculate an effective 
Integral gain.

Parameters in the Auto Gain Panel: 

Gain start The starting value of the integral gain sweep.

Range or Settings: Recommended settings are 0.10 for TappingMode, 0.5 
for Contact Mode.

Gain end The ending value of the integral gain sweep.

Range or Settings: Recommended settings are 1.0 for TappingMode, 10.0 
for Contact Mode.

Gain incr. The increment step for each integral gain test.

Range or Settings: 0.0 to 5.0; Recommended settings are 0.1 for Tapping-
Mode, 0.5 for Contact Mode.

Pro. Gain factor Proportional gain is set to: 

Range or Settings: 0.0 to 10.0; Recommended value is 1.50

Max shift The percentage of pixels to shift the Retrace line to match the trace line dur-
ing the correlation routine. The more closely the Trace and Retrace lines 
match, the lower the TMR will be, and the more effective the Auto Gain fea-
ture.

Range or Settings: 0 to 0.2; recommended setting is 0.02 (or 2%)

Gain offset Specifies the number that determines the final, best fit Integral gain. Allows a 
change in the value produced by Auto Gain. 

Range or Settings: 0.0 to 2.0; recommended setting is 0.95 (or 95%)

Lines/gain The number of lines to test and average for each integral gain step. Optimal 
settings are between 4 and 8. This, like Max shift, allows for a more accurate 
determination of TMR. 

Range or Settings: 1 to 20, with a default setting of 8

Proportional gain F Integral gain×=

Pro. Gain factor Integral gain×
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2.3 Tips on Using Realtime

Please refer to the following Realtime commands available on the NanoScope software:

• Using the Image Interface Section 2.3.1

• Multiple Channels Section 2.3.2

• Hints to Optimize the Engage Button Section 2.3.3

• Scan View Parameters Tips Section 2.3.4

• Channels Parameters Tips Section 2.3.5

• Feedback Parameters Tips Section 2.3.6

2.3.1 Using the Image Interface

There are various commands available for use during a Realtime scan. Below is a description of 
these commands (see Figure 2.3a).

Figure 2.3a   Image for Processing
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Buttons

• Measure: Allows you to draw a line to make measurements.

• Pan: From a zoomed image, the user can pan around to other areas of the original 
image.

• Data Zoom: Left-click, hold, and drag out a box. Release the mouse button and the 
image will automatically zoom in to the area of the box. The original scan size remains 
the same.

• Zoom: Allows you to zoom in on a region of interest. 

• When you select Zoom a bounding box appears on the image display. Left-click on 
the outer edge of the box to resize. 

• Left-click in the center to reposition. 

• Click the Execute button to zoom in. This updates the Scan size and X and Y 
Offset parameters.

• Execute: Executes the Zoom and Offset commands. You must select the Zoom or 
Offset button for the Execute button to appear.

• Offset: Allows you to center the scan at the region of interest. 

• When you select Offset a crosshair displays at the center of the image.

• Left-click and hold the crosshair to reposition it.

• Click the Execute button to center the scan. This updates the X and Y Offset 
parameters.

Right-Clicking on the Image

By right-clicking on the image, you will get a menu that allows you to perform the following tasks:

• Copy Clipboard: Copies the image to the Microsoft™ clipboard.

• Tooltip Info Level:

• Basic

• Medium

• Advanced

• None
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Right-Clicking on the Color Bar

Right-clicking on the color bar along the right side of the image (see Figure 2.3a) will produce a 
Color button (see Figure 2.3b). Clicking on this Color button will open the Image Adjust menu, 
where you can perform the following image adjustments (see Figure 2.3c):

Figure 2.3b   Color Button

a.  You can adjust the color by changing the Contrast or Offset settings.

• Contrast—Number (-10 to +10) designates contrast of colors in displayed image 
(e.g., 0 shows little change, while 10 shows highest contrast).

• Offset—Number (-128 to +128) designates offset of colors in displayed image (e.g., 
120 shows illuminated background on image).

b. Clicking the Color Reset button will change all the current readings to the default 
settings.

Figure 2.3c   Image Adjust Menu

c. To change the color table, position the mouse over the color bar on the right side of the 
image. Click and hold the left mouse button, then drag the mouse from left to right to 
scroll through the different color tables.

 Using the Mouse Within a Captured Image in Measure Mode

Left-click anywhere in image 
window, drag line out, and 
release

Creates a line of X length, at Xo of angle in the image window.

Place cursor on line Displays length and angle values of line in the image window.

Place cursor on line, click 
and hold left button, and 
drag

Allows you to drag the line anywhere in the image window.
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Figure 2.3d   Image Cursor Menu

Using the Grid Display

Measurement cursors for the Scope View are provided to the left and right of the Grid Display. You 
can bring the cursors into the grid by placing the mouse cursor onto the measurement cursors, 
clicking and holding the left mouse button, and dragging them onto the grid. When you place the 
mouse cursor onto a measurement cursor, the cursor will change from a plus sign to a horizontal or 
vertical arrowhead cursor, which indicates you can grab and drag this cursor.

Click and hold on either end 
of line and drag

Changes length and/or the angle of the line.

Right-click Clicking the right mouse button when the cursor is on the line 
accesses the Image Cursor menu (see Figure 2.3d).

• Delete—Deletes the line.

• Flip Direction—Switches the line end to end.

• Show Direction—Adds small arrowhead to the line to 
indicate its the direction.

• Set Color— Allows you to changes the color of the 
line.

• Clear All—Deletes the line.
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Right-clicking on the grid will bring up the Grid Parameters menu (see Figure 2.3e) and allow 
you to make the following changes:

Color Allows operator to change the color of the:

• Curve (data)

• Text

• Background

• Grid

• Minor Grid

• Markers

Filter Typically used for a Profiler Scan.

• Type—Allows the user to plot the mean, maximum or 
minimum y-value per x-value.

• Points —Allows user to plot multiple vertical axis 
(y-)values at each horizontal axis (x-)value. Select 4K, 
8K, 16K or 32K Points to limit the display to 4, 8, 16 
or 32 times 1024 points.

Minor Grid Places a minor grid in the background of the Vision Window.

Scale Allows user to auto scale, set a curve mean, or set their own data 
range

Translate Offsets the curve by the placement of a horizontal cursor on the grid

Line Style For each curve, the operator can choose a connect, fill down, or point 
line.

User Preferences Restore—Reverts to initial software settings

Save—Saves all changes operator has made during this session. This 
becomes the new default settings.

Copy Clipboard Copies the grid image to the Microsoft Clipboard

Print Prints out the current screen view to a physical printer

Export Exports data in bitmap, JPEG or XZ data format

Active Curve Determines which curve you are analyzing
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Figure 2.3e   Grid Parameters

2.3.2 Multiple Channels

It is often helpful to view more than one channel of data simultaneously. Scan-Dual and Scan-
Triple can be selected upon first opening Realtime by clicking on the appropriate check boxes in 
the Add Views to Realtime1 dialog box (see Figure 2.3f). 

Figure 2.3f   Add Views to Realtime1 Dialog Box

If you are already in Realtime, you can also access multiple channel views by right-clicking on the 
Realtime icon in the Realtime workspace (see Figure 2.3g).

• Click Add View > Scan-Dual to add a window with two channels displayed.

• Click Add View > Scan-Triple to add a window with three channels displayed.

Note: To open a single channel, click Add View > Scan Display.
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Figure 2.3g   Add Views to Realtime1 Menu

Image controls are displayed beneath each image (see Figure 2.3h). 

Figure 2.3h   Scan-Dual View

In Scan-Triple, the Scan Line, Scan Direction, Data Scale, Data Center, Realtime Planefit, and 
Offline Planefit settings are not displayed below the images and must be accessed using the 
parameters list to the right of the image display (see Figure 2.3i).

Realtime Icon
in Workspace

Scan Controls
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Figure 2.3i   Scan Triple Dialog Box and Location of Channel 2 and 3 Parameters

Note: All three channel display options are included among the Realtime views 
presented as options to include in the workspace upon first opening the 
Realtime workspace (see Figure 2.3h).

Typical examples of the use of multiple channels:

• To simultaneously monitor both a TappingMode height image and a phase image of the 
same region.

• To simultaneously collect a topography and MFM image.

2.3.3 Hints to Optimize the Engage Button

• When used with stepper-motor-engagement microscopes, the tip is lowered under 
program control. While the tip is being engaged, the tip travel distance is shown in the 
center of the status bar on the Control Monitor. When the surface is detected, the 
workstation beeps, starts the Realtime imaging process, and displays Engaged in the 
status bar on the Control Monitor.

• During automatic engagement, the tip will travel a preset distance (200µm for 
Dimension AFMs, 125µm for MultiMode AFMs). If the sample surface is not detected 
in this distance, an error message will be displayed.

• If the tip is on the surface and the Z center voltage indicates that the piezo is near full 
extension or retraction, the tip may be withdrawn and re-engaged to center the Z center 
voltage. Alternatively, the Tip Up and Tip Down subcommands of the Motor command 

Channels 2 and 3 Parameters
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can be used to center the Z voltage. If the Z center position indicates that the scanner is 
retracted, click the Tip Up button until Z center is near 0V (0.50V).

• Pressing Ctrl-F after the Engage command has been executed will cause a false engage 
to occur after the SPM safety height is recycled for Dimension, causing the Realtime 
software to start scanning independently of whether the surface has been detected or not.

2.3.4 Scan View Parameters Tips

Optimizing the Scan Size Parameter

• The Scan size and offsets can be set by using the Zoom and Offset subcommands in 
Scan View or in tabbed panels.

• Non-zero X and Y offsets reduce the maximum Scan size. Each volt of X or Y offset 
reduces the maximum scan size by 2V.

• Having a non-zero Scan angle will reduce the maximum allowable Scan size.

• The maximum Scan size will also decrease as the Scan rate increases.

Optimizing the X Offset, Y Offset Parameter

• These parameters use the sample as the position reference. Therefore, a more negative X 
offset value will move a feature in the current image to the left on the Image display 
Similarly, a more negative Y offset moves a feature in the current image down on the 
Image display.

• Using the left-arrow and right-arrow keys when the cursor is in these parameters will 
decrement and increment these parameters by 10% of the Scan size.

• Using the Zoom or Offset subcommands on the automatically changes the value of X 
and Y offsets.

Optimizing the Scan Size and Scan Rate Parameters

• The Scan size and height of features on the sample will affect the maximum Scan rate 
that should be used on a given sample. Scan rate should be set to a rate that allows the 
tip to closely track the sample surface in both trace and retrace. In general, larger scans 
and taller features require slower scan rates.
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2.3.5 Channels Parameters Tips

Optimizing the Data Type Parameters

• The system can display up to three Realtime images on the Display Monitor.

• The Data type parameter does not switch the operating mode of the instrument, it 
simply changes the source of the data displayed. 

Optimizing the Data Scale Parameters

• Data beyond the setting of the Data scale is clipped for the Realtime display. Captured 
data, however, is not clipped. Independent of the settings of this parameter, the captured 
data will be correct unless it exceeds the maximum vertical range of the scanner.

• Each Data type retains separate settings for Data scale.

• Data Center is used to manually offset the trace data when Realtime Planefit is set to 
none.

The conversion of volts to nm or nA, is dependent on the value Sensitivity Detector parameters in 
the Tools > Calibrate > Detector panel.

For example, nanometers of cantilever deflection are calculated using the Sensitivity parameter in 
the Force Calibrate panel.

Optimizing Realtime Planefit Parameters

The setting of Realtime Planefit only affects the displayed data. It does not affect the captured data 
The parameters are described below.

• None displays the raw data in the scope display.

• Offset applies a zero order correction to each line of data so that the average height of 
the line is centered in the scope display.

• Line applies a 1st order correction, removing both tilt and offset from each line of data. 

Note: If features are not evenly spaced along the scan line, using Realtime Planefit 
Line can result in artificial tilting of the scan line.

Optimizing the Offline Planefit Parameter

• The None option should only be used in special cases. The Offset and Full options 
provide greater dynamic range in the data to reduce round-off and other errors in 
subsequent calculations.

• The Offline > Modify > Flatten and Planefit commands can also be used to level the 
data after it has been captured.
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2.3.6 Feedback Parameters Tips

Optimizing the STM Feedback Parameters

• The Boost and Log modes are preferable for most STM samples, because the tip 
responds in a more symmetric manner (i.e., the same going up and coming down). Log 
and Boost modes tend to linearize the entire feedback loop since Z ≈ ln(i). The 
asymmetric response of the Lin setting distorts data.

• Use of Boost mode allows the Proportional gain and Integral gain values to be 
reduced and is preferable for large scans having high, vertical features (e.g., integrated 
circuits).

• When Boost mode is selected, the Integral and Proportional gains are often best set to 
lower values than when Log mode is used.

Optimizing the Integral and Proportional Gain

• The Integral gain is usually the major contributor to the performance of the feedback 
loop due to its “long term” influence. For this reason, it is usually adjusted before 
proportional gain.

• The integral term in the feedback calculation has the highest gain at low frequencies, 
and its effects diminish with increasing frequency.

• A nominal Integral gain value may be obtained by slowly increasing the value until the 
piezo begins to oscillate, then decreasing the value until oscillation ceases. Oscillation 
effects are best viewed using Scope Mode and show up first in error signal (i.e 
deflection or amplitude).

• The Proportional gain parameter is typically set to 35 to 100% more than the Integral 
gain value.

Optimizing the Look Ahead Gain Parameter

• Look ahead gain adds information from the previous scan line to the feedback loop 
calculation, so it is most useful for samples with long features oriented perpendicular to 
the scanning direction.

• Use Look ahead gain discreetly. For many surfaces, 0.5 to 0.8 is nominal.
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2.4 Force Curves

Force Curves ramp tip-sample separation while holding the X, Y position constant in the center of 
the previous scan. The scanner’s vertical position is plotted versus either the cantilever deflection 
(Contact AFM), or the amplitude of the cantilever oscillation (TappingMode). Alternatively, the 
cantilever deflection or oscillation amplitude can be plotted relative to a user-designated input 
signal.

2.4.1 Force Curves Procedure

Ramp Settings

To obtain force curves, it is necessary to first engage in Scan Mode using one of the Scan Views 
(see Preparing a Dimension Series AFM for a Realtime Scan Section 1.4.2), then switch to 
Ramp mode. If you want to calibrate deflection sensitivity, use a hard sample in the following 
procedure.

1. Activate Ramp mode (this causes the system to stop scanning, and the probe to position 
above the center of the previous image):

a. Click the Ramp node in the workspace or any visible ramp plots.

                              Or

b. Add the Ramp Parameter List and Ramp Plot(s) to the workspace. Right-click 
Realtime or click the Acquire menu, and select Ramp Parameter List and Ramp 
Plot. It is possible to view three Ramp Plots at a time by adding ramp plots to the 
workspace. Arrange the Ramp Plot(s) and Ramp Parameter List so that all are 
viewable.

Note: See Ramp Parameter List Section 2.4.2 - Feedback Panel Section 2.5.2 for a 
thorough discussion of the Ramp Parameter List Parameters. When in Ramp 
mode, a ramp- specific menu also displays, the Ramp menu. See Ramp Menu 
Section 2.5.3 for more information.

2. Enter the following parameter settings in the designated panels of the Ramp Parameter 
List:

a. In the Ramp panel select:

Parameter Setting

Ramp output Z

Ramp size 1.00µm
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b. In the Channel 1 panel select:

Gather Force Curves

1. Select Ramp > Run continuous from the menu bar.

2. While watching the Ramp View and the Display Monitor’s bar graph (see Figure 2.4a), 
increase the Z Scan Start to move the tip closer to the sample.

Figure 2.4a   Bar Graph

3. When the force curve suddenly rises, the tip has reached the surface (see Figure 2.4b).

Z scan start 0nm

Scan rate 1.00Hz

Number of samples 512

Parameter Setting

Data Type Deflection

X Data Type Z

Display Mode Deflection vs. Z

Parameter Setting
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Figure 2.4b   Force Curve

4. Click the Capture icon to save the force curve. Make note of the file name in the status bar 
(lower right corner of the window).

Calibrate Deflection Sensitivity

It is often necessary to calibrate the deflection sensitivity of a force curve. The deflection sensitivity 
depends upon several factors, such as the position of the laser spot on the cantilever, so it needs to 
be calibrated each time you change the probe. Use the following procedure to determine the 
deflection sensitivity:

1. Move two cursors onto the Deflection vs. Z plot (see Figure 2.4c).

Figure 2.4c   Realtime Force Curve

2. Arrange the cursors so that they surround the contact (steepest) portion of the graph 
(see Figure 2.4d).
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Figure 2.4d   Force Curve Cursors

3. Select Force > Update Sensitivity. The software will automatically calculate the deflection 
sensitivity.

Figure 2.4e   Update Sensitivity

4. Click OK to accept this deflection sensitivity in the dialog box that displays, and it will 
automatically be entered into the Sens. DeflSens parameter in the Channel Data panel to the 
right of the plot (see Figure 2.4c).

Figure 2.4f   Deflection Sensitivity Dialog Box

5. Replace the hard sample with the sample you wish to analyze. The deflection sensitivity will 
remain applicable as long as the position of the laser spot on the cantilever does not change.
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2.4.2 Ramp Parameter List

When you open Ramp Parameter List, the Ramp Parameter List box displays (see Figure 2.4g). 
All force curve parameters can be set in the Ramp Parameter List. The Ramp Parameter List is 
sectioned into seven panels. The parameters in each panel are defined in the following sections:

• Ramp Panel on page 94

• Mode Panel on page 96

• Channel (1, 2 or 3) Panels on page 98

• Feedback Panel on page 99
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Figure 2.4g   Ramp Parameter List
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2.4.3 Ramp Panel

Ramp Output: Specifies the Ramp Channel.

Ramp Size: Specifies the range of the Ramp Channel. Visible only if the Ramp Channel 
parameter is set to Z. Settings depend on the specified units.

Z Scan Start: Visible only if the Ramp Channel parameter is set to Z. Z scan start is the bottom 
position of the Z-axis scan as represented on the Display Monitor’s bar graph. When the Force 
Calibrate command is first accessed during imaging, this value is automatically set to the Z 
Center Position.

Note: The value of this parameter will need to be increased to move the sample closer 
to the cantilever in the case where there is no deflection of the cantilever for a 
displacement of the sample.

• Range and Settings: The range of this parameter depends on the scanner. The units of 
this parameter are volts or nanometers, depending on the setting of the Units parameter.

Note: While the user is ramping Z in Force Calibrate, the feedback parameters (i.e., 
type, count and value) are inactive.

Scan Rate: The Scan Rate sets the ramping rate. Changing this value effects the Forward and 
Reverse Velocities.

Forward Velocity: Forward Velocity of the tip (in µm/s) as it approaches the surface. Increasing 
this value increases the Scan Rate.

Reverse Velocity: Reverse Velocity of the tip (in µm/s) as it retracts from the surface.

X Offset: Controls the center position of the scan in the X direction.

Y Offset: Controls the center position of the scan in the Y direction.

Number of samples: Number of data points collected during each upward (retraction) and 
downward (extension) travel cycle of the piezo. The Number of samples parameter sets the pixel 
density of the force curve. This parameter does not change the Z scan size.

• Range or Settings: 4 to 64,000 data points displayed per extension and retraction cycle.
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Spring Constant: Records the spring constant of the cantilever that is currently being used. This 
parameter is input by the user and is recorded along with each force plot captured. It is used for 
Offline analysis of the force plot. It is not critical to set the Spring constant in Realtime, since it 
can be altered in the Offline analysis of the captured force plot. The Spring constant is necessary to 
display a graph of force vs. separation when conducting Offline analysis of the force plot.

Plot Units: Switches parameters in the control panels between units of Volts (V) or Metric units 
(nm or µm). Changing this parameter also changes the setting of the Units parameter on the AFM 
control panel.

• Range or Settings: Volts (V), Metric (nm) or Force (nm)

Display Mode: The portion of a tip’s vertical motion to be plotted on the force graph.

• Range or Settings:

• Extend—Plots only the extension portion of the tip’s vertical travel.

• Retract—Plots only the retraction portion of the tip’s vertical travel.

• Both—Plots both the extension and retraction portions of the tip’s vertical travel.

• If a channel other than Z is chosen, Display mode will not be available in Offline 
view.

X Rotate: Allows the user to move the tip laterally, in the X direction, during indentation. This is 
useful since the cantilever is at an angle relative to the surface. One purpose of X Rotate is to 
prevent the cantilever from plowing the surface laterally, typically along the X direction, while it 
indents in the sample surface in the Z direction. Plowing can occur due to cantilever bending during 
indentation or due to X movement caused by coupling of the Z and X axes of the piezo scanner. 
When indenting in the Z direction, the X Rotate parameter allows the user to add movement to 
scanner in the X direction. X Rotate causes movement of the scanner opposite to the direction in 
which the cantilever points. Without X Rotate control, the tip may be prone to pitch forward during 
indentation. Normally, it is set to about 22.0º.

• Range or Settings: 0 to 90º; most effective values are between 15 and 25º.
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2.4.4 Mode Panel

Trigger Mode: Limits the amount of force exerted by the tip upon the sample. It is possible to 
operate the trigger independent of drift (Relative) or at some arbitrarily fixed point (Absolute) 
depending on the trigger settings.

Data Type: Channels may be assigned for triggering to any input signal available including: 
Deflection, Amplitude, Phase or Friction data.

Trig Threshold: The value of the cantilever deflection, as measured by the photodetector, desired 
for the indentation or scratch. The Trigger threshold defines the maximum force applied to the 
sample corresponding to the upper right-most point on the force plot.

• Range or Settings: -10V to +10V, depending on the Deflection Limit. Try 0.5V to 1.0V.

Trig Direction: Determines the direction of the trigger and allows for a Positive, Negative, or 
Absolute trigger slope. In this way, the trigger may be configured to activate on either the positive 
or negative direction of the force curve.

 

Start Mode: Start mode allows you to switch between the various force modes without returning to 
image mode. 

• Range or Settings:

• Calibrate—Produces standard Force Mode force plots. Includes the ability to 
continuously cycle the tip up and down.

• Step—Produces standard Force Mode force plots, with added control to step the tip 
towards the surface.

End Mode: Determines the location of the tip when the microscope is returned to Image mode. 
Choices include Extended, Retracted, or Surface.

Z Step Size: The change in tip height per step when using force step.

Auto Start: When enabled, autostarts Force mode when entering from Image mode. If off, you 
must start ramping by clicking the Continuous or Single icon, or by selecting the proper menu 
selection under the Ramp menu.

Negative Trigger Direction Positive Trigger Direction

Z position - 0.10 µm/div Z position - 0.10 µm/div
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Surface Delay: Specifies a delay when the tip reaches the point closest to the sample.

• Range or Settings: 0 to 200 seconds

Retracted Delay: Similar to Surface delay, this value specifies the duration of the delay when the 
piezo is at the top of the cycle (farthest away from the sample).

• Range or Settings: 0 to 200 seconds

Auto Offset: Because of Z drift (thermal drift, piezo drift, etc.), the sample will sometimes drift out 
of Z range. When enabled, Auto Offset uses the Setpoint value from Image mode to Feedback and 
find the surface and resume Force imaging. The Auto Offset feature is a form of drift correction.

Strip Chart Rate: Frequency of (Z-position, deflection) data point acquisition for strip chart (only 
available for Picoforce and Nanoman).

• Range: 20kHz to 0.01Hz. Typical value: 1kHz

Strip Chart Size: Time interval over which (Z-position, deflection) data points are displayed in 
strip chart.

• Typical value: 10 to 10,000 sec.

Note: Although the strip chart collects and displays data over the time interval defined 
by clicking Start, then later, Stop, this data is not saved for subsequent use 
until the Capture icon (shown) is clicked. If Capture is clicked while strip 
chart data is being taken, what is saved begins at the start of the chart (sooner 
than the icon is clicked).
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2.5 Auto Panel

The Auto Panel parameters are only available when Autoramping.

Columns: Number of points in the Y axis.

Rows: Points in the X axis.

Column Step: Offset distance between points in the X direction.

Row Step: Offset distance between points in the Y direction.

Threshold Step: The trigger point at which the deflection or the current activates the position 
change.

Capture: State is either enabled or disabled. When enabled, the software records and stores the 
ramp data for each data point in the matrix of rows and columns.

2.5.1 Channel (1, 2 or 3) Panels

Data Type: Channels may be assigned to any input signal available including: Deflection, 
Amplitude, Phase, Friction and so on. Any channel may be switched to Off, however, at least one 
channel is always on.

X Data Type: Type of data that the channel data is being compared to. This data displays on the X-
Axis of the scope grid.

Data Scale: Voltage range for the vertical axis of the force curve plot. 

Note: This can be overridden by setting Autoscale On for the plot.

Data Center: Offsets centerline of scan by the amount entered. 

Note: The Data center offset does not become a permanent part of the data.

• Range or Settings: Depends upon the input signal, generally ± one-half of data scale 
maximum.

Deflection Sens.: Defines the conversion factor from cantilever deflection signal voltage to 
nanometers of cantilever displacement (in nm/V) using data in the contact region of a force plot.

Plot Invert: Inverts data along the Y-axis, effectively turning valleys into mounds and vice versa.

Ave. Points: Averages multiple points to smooth the curve.

Effective BW: A display (you cannot input a value to it) representing the sampling frequency with 
display averaging taken into account:

                     Effective BW = (force plot sampling rate)/(Ave. Points)
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Phase Offset: Shift horizontal position of plot to compensate for averaging of endpoint data.

Note: The numerical values of the two Phase Offset parameters can be ignored; set 
them to whatever values minimize the apparent hysteresis. Particularly when 
Forward Velocity and Reverse Velocity are unequal, the same numerical value 
for each Phase Offset may not correspond to an identical displacement on each 
axis.

Display Mode: The portion of a tip’s vertical motion to be plotted on the force graph.

Range or Settings:

• Extend—Plots only the extension portion of the tip’s vertical travel.

• Retract—Plots only the retraction portion of the tip’s vertical travel.

• Both—Plots both the extension and retraction portions of the tip’s vertical travel.

• If a channel other than Z is chosen and the force curve is captured Offline, Display 
mode may not be available in Offline view.

X Rotate: Allows the user to move the tip laterally, in the X direction, during the ramping of Z. 
This is useful because the cantilever is at an angle relative to the surface. One purpose of X Rotate 
is to prevent the cantilever from plowing the surface laterally, typically along the X direction, while 
it indents in the sample surface in the Z direction. Plowing can occur due to cantilever bending 
during indentation or due to X movement caused by coupling of the Z and X axes of the piezo 
scanner. When indenting in the Z direction, the X Rotate parameter allows the user to add 
movement to scanner in the X direction. X Rotate causes movement of the scanner opposite to the 
direction in which the cantilever points. Without X Rotate control, the tip may be prone to pitch 
forward during indentation. Normally, it is set to about 22.0º. 

Range or Settings: 0 to 90 degrees; most effective values are between 15 and 25º.

2.5.2 Feedback Panel

Only the Force Curve-applicable menu parameters are described below:

Deflection Setpoint: Defines the deflection signal, and therefore the tip-sample force, maintained 
by the feedback loop.

• Range or Settings: ± 10.0V maximum

Deflection Limit: Use this parameter for attenuating the input voltage signal (appears only when 
performing Contact AFM).

• Range or Settings: 2.500V for regular imaging and 20.00V in Force Mode only
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2.5.3 Ramp Menu

While the microscope is engaged and in Realtime mode, opening the Ramp parameters will 
display the Ramp Menu.

Figure 2.5a   Ramp Menu

Ramp Menu Definitions

Run Continuous: The tip is continuously lowered and raised by a distance equal to the Ramp size. 
This is the normal, default motion during Force Calibrate. “Raising” and “lowering” are relative 
to your system (e.g., On Dimension Series SPMs, the tip is raised and lowered to the surface; 
however, other SPMs raise and lower the sample beneath the tip).

Run Single: Lowers and raises tip once by a distance equal to the Z scan size, then halts.

External Trigger: (Not available)

Stop: Halts all tip movement.

Retract: The Z-axis piezo retracts to its limit in preparation for Approach Continuous. This 
command does not initiate motor movements.

Approach Continuous: The tip lowers to the surface and raises in a controlled series of steps, then 
indexed by the Z step size (see Scan Mode panel) distance. This process continues downward until 
the tip encounters the surface. When tip deflection exceeds the Threshold Step amount, Approach 
Continuous halts and the resulting force curve displays.

Approach Single: The tip is lowered to the surface and raised in a single, controlled step. This 
process is halted if the surface is encountered by the tip, causing deflection exceeding the Step 
threshold amount. The resulting force curve is displayed.

Auto ramp: Begins auto ramping as defined by the parameters specified in the Auto Panel.
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