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Chapter 3   Analysis Commands

The Analysis commands relate to analyzing the surface behavior of materials on images captured in 
Realtime mode. These commands are known as image processing or analysis commands. The 
commands contain views, options and configurations for analysis, modification, and storage of the 
collected data. The analysis may be automated (i.e., in autoprograms) or completed manually. In 
general, the analysis commands provide methods for quantifying the surface properties of samples.

Please refer to the following analysis commands available in Analyze menu of the NanoScope 
software:

• Image:  Section 3.1

• 3D Surface Plot:  Section 3.2

• Zoom:  Section 3.3

• Depth:  Section 3.4

• Power Spectral Density:  Section 3.5

• Roughness:  Section 3.6

• Section:  Section 3.7

• XY Drift: Section 3.8

• Multiple Channel Analysis:  Section 3.9

• AutoProgram:  Section 3.10



Analysis Commands
Image

100 Nanoscope Software 6.12 User Guide Rev. C

3.1 Image

The term Image refers to the data captured in Realtime mode. The current image processing 
capabilities include data analysis, modification, presentation and storage of the images. The source 
of the image includes: 

• Data captured in Realtime scanning mode

• New image files created using modification or analysis commands

For general information on the interface and basic functions in image processing, see Using the 
Image Interface: Section 3.1.1.

3.1.1 Using the Image Interface

To process an image, you must open an image file. This can be done by:

• Clicking File > Open. When the Open NanoScope File dialog box opens (see Figure 
3.1a), select Captured File (*.*) and click the Ok button.

Figure 3.1a   Open NanoScope File Dialog Box

• Double-click an image in the Browse dialog box. The new image appears in the client 
window (see Figure 3.1b).
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Figure 3.1b   Image for Processing

Image Processing Add View Commands

The Offline Add View menu for image processing differs from the Realtime Add View commands. 
The commands include measurement, analysis and modification commands (see Figure 3.1c).

Figure 3.1c   Image Processing Functions Menu
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Right-Clicking on the Image

By right-clicking on the image, you will get a menu (see Figure 3.1d) that allows you to perform 
the following tasks:

Figure 3.1d   Image Click

• Rotating Line—Left-click, hold, and drag out a line. Release the mouse button to end 
the line.

• Box (for some analyses)—Left-click, hold, and drag out a box and release the mouse 
button.

Note: Left-clicking in the center of the box allows you to translate. Left-clicking on 
edges allows you to change the box size.

• Copy Clipboard—Copies the image to the Microsoft clipboard.

• Tooltip Info Level:

• Basic

• Medium

• Advanced

• None

• Export—Exports the image as a bitmap or JPEG (WYSIWYG), or Full Image (pixel by 
pixel data).
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Image Buttons

Clicking the Image buttons above the captured image (see Figure 3.1e) performs the following 
functions:

• Data Zoom—Left-click, hold, and drag out a box. Release the mouse button and the 
image will automatically zoom in to the area of the box.

• Pan—From a zoomed image, the user can pan around to other areas of the original 
image.

• Measure—Left-click, hold, and drag out a line. Length of line appears in a box near the 
line any time cursor is on the line.

Right-Clicking on the Color Bar

Right-clicking on the color bar along the right side of the image (see Figure 3.1e) will produce a 
Color Scale button. Clicking on this Color Scale button will open the Color Scale dialog box, 
where you can perform the following image adjustments:

• Contrast—Number (-10 to +10) designates contrast of colors in displayed image (e.g., 
0 shows little change, while 10 shows highest contrast).

• Offset—Number (-128 to +128) designates offset of colors in displayed image (e.g., 
120 shows illuminated background on image).

• Data Scale—Designates the vertical range of the image, corresponding to the full 
extent of the color table.

• Table—Designates the Color Table number.

Figure 3.1e   Image Adjustment Controls

Image
Buttons

Color Scale
Menu

Color
Scale 
Dialog Box

Color Bar



Analysis Commands
Image

104 Nanoscope Software 6.12 User Guide Rev. C

 Using the Mouse Within a Captured Image

Figure 3.1f   Image Cursor Menu

Left-Click anywhere in image 
window, drag line out, and 
release

Creates a line of X length, at Xo of angle in the image window

Place cursor on line Displays length and angle values of line in the image window

Place cursor on line, click 
and hold left button, and 
drag

Allows you to drag the line anywhere in the image window

Click and hold on either end 
of line and drag

Changes length and/or the angle of the line

Right-Click Clicking the right mouse button when the cursor is on the line 
accesses the Image Cursor menu (see Figure 3.1f)

• Delete—deletes the line.

• Flip Direction—switches the line end to end.

• Show Direction—Adds small arrowhead to the line to 
indicate direction.

• Set Color—Allows you to change the color of the line.

• Clear All—Deletes all lines.
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3.2 3D Surface Plot

The 3D Surface Plot View displays the selected image with color-coded height information in a 
three-dimensional, oblique perspective. You can select the viewing angle and illumination angle for 
a modeled light source. 

You can view the 3D Surface Plot View using one of the following methods:

• Right-click on the image name in the Workspace and select Add View > 3D Surface 
Plot from the popup menu.

                                     Or

• Select Analyze > 3D Surface Plot from the menu bar.

                                     Or

• Click the 3D Surface Plot icon in the upper toolbar. 

The Surface Plot panel appears and allows formatting of image data on the Display Monitor (see 
Figure 3.2a). 

Figure 3.2a   3D Surface Plot Window
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3.2.1 Parameters in the 3D Surface Plot Inputs

The Projection Type, Plot Type, and Label Type 3D Surface Plot parameters can be changed by 
clicking on the related window and selecting from the drop-down menus. The remaining 
parameters may be changed by typing the desired information in the related window or by use of 
the keyboard and mouse keys. 

• To zoom in or out on the image, hold the control key down and slide the mouse up and 
down on the image while holding the left mouse button.

• To pan, hold the shift key down and move the mouse up, down, left, or right on the 
image while holding the left mouse button.

• Clicking and holding the right mouse button down while moving the mouse left and 
right changes the light rotation on the image. This is only available when plot type is set 
to mixed

• Clicking and holding the right button while moving the mouse up down changes the 
light pitch. This is only available when Plot Type is set to Mixed.

The function of the Input parameters are:

Projection Type Select either Parallel or Perspective 

• In parallel mode, the viewing volume does not 
change, which has the affect keeping objects the 
same size as they are projected. This is useful for 
maintaining the size and angle of objects between 
the front and back of the view. 

• In perspective mode, objects appear to get smaller 
the further away they are from the eye. This is how 
the objects are perceived in the real world.

Plot Type Select Height, Wire, or Mixed

• Height displays image with the height values 
encoded according to the color table.

• Wire displays image as a line representation of the 
scanned data.

• Mixed displays a combination of height and 
illumination encoding which is used on the 
displayed image. 

Rotation The Rotation parameter in the Surface Plot Inputs 
changes as the viewing angle in changed by rotating the 
displayed image about the Z axis relative to its captured 
orientation.

Pitch The Pitch parameter in the Surface Plot Inputs changes 
as the viewing angle by manually changing the pitch of the 
Y axis in the three-dimensional Surface Plot image.
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The Export button allows the operator to export the image in the window to either JPEG or bitmap 
format. The graphic will be stored in the Capture folder.

Light Rotation The Light Rotation parameter in the Surface Plot Inputs 
rotates the light source in the horizontal plane (along the Z 
axis). This is only available when the Plot Type is set to 
Mixed.

Light Pitch The Light Pitch parameter in the Surface Plot Inputs 
changes the viewing angle by selecting the pitch of the Y 
axis in the three-dimensional Surface Plot image. This is 
only available when the Plot Type is set to Mixed.

Illumination Weight Selects the percentage of the imaginary light source mixed 
with the color-encoded height information when the Plot 
type is set to Mixed.

Label Type The Label Type parameter in the Surface Plot Inputs 
selects whether labels, axes, and the view/illumination 
controller are displayed with the image.

Current Channel Displays the current channel of multichannel scan dis-
plays.
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3.3 Zoom

Use the Zoom function to extract an image from a large Version 6 image for Version 5 analysis. 
NanoScope Version 5 software features a number of Analysis functions currently not available in 
Version 6 software. Zoom will produce the largest Version 5 image size possible within the 
bounded region (128 x 128, 256 x 256 or 512 x 512). 

Note: 512 x 512 is the most common image size, and will be used as the example 
throughout the rest of this section.

Note: The image produced by this analysis is Version 5 compatible, however, if the 
image is later processed by a Version 6 analysis, the image may no longer be 
Version 5 compatible.

3.3.1 Zoom Procedure

Use the Zoom analysis to isolate a 512 x 512 portion of a high resolution image.

1. Open a large Version 6 image (larger than 512 x 512).

2. You can view the Zoom View using one of the following methods:

• Right-click on the image name in the Workspace and select Add View > Zoom from 
the popup menu.

                                     Or

• Select Analyze > Zoom from the menu bar.

                                     Or

• Click the Zoom icon in the upper toolbar.  

3. The selected image opens in the Zoom dialog box (see Figure 3.3a).
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Figure 3.3a   Initial Zoom Dialog Box

4. A bounding box appears in the image (see Figure 3.3a). Place the cursor inside the box, and 
while holding the mouse button, move the box to the location of interest. The box is 
restricted to the largest possible Version 5-compatible image size (usually 512 x 512).

5. Once the box is in place, select the New File Name button. Select a location and name for the 
new image. 

6. Select the Create Image button. 

a. If the Auto Open New File parameter under Inputs is set to Yes, the image opens in the 
default image view (see Figure 3.3b).

Bounding
Box
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Figure 3.3b   New Zoom Image Dialog Box

b. If the Auto Open New File parameter under Inputs is set to No, The new image will be 
saved in the designated directory but will not automatically display.

7. Use this new image for Version 5 analysis.
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3.3.2 Zoom Interface

Input Parameters

Results Parameters

Zoom Buttons

New File Name Displays the path of the extracted image file. 

Auto Open New File Settings:

• If Yes is selected, after selecting the Create Image button the 
newly extracted image open. 

• If No is selected, the new file will be created and saved in the 
designated directory, but will not automatically display.

Method Settings:

• Interpolate—Data points will be interpolated to create new 
image.

• Replicate—Data points will be used as is to create a new 
image.

V5 Compatible The image created using the Zoom function is compatible with Nano-
Scope Version 5 software.

Number of x Points Number of x points in the new image.

Number of y Points Number of y points in the new image.

Aspect Ratio Aspect ratio of the new image.

Scan Size Scan size of the new image. The units of this parameter are volts if the 
Units parameter (Other Controls panel) is set to Volts. The units are 
linear distance (nm or µm) if the Units parameter is set to Metric.

Error Possible errors:

• No Error—(Default)

• Not Enough X Points—Original image has less than 512 
points/line.

• Invalid Aspect Ratio—Zoomed image results in an aspect 
ratio greater than 256:1.

• File Write—A disk error occurred.

• Unknown—An unknown error has occurred.

New File Name Browse for the location to save the new image.

Create Image A Version 5 compatible image is created from the portion of the high 
resolution image that is contained in the bounding box.
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3.4 Depth

To analyze the depth of features you have numerous choices which measure the height difference 
between two dominant features that occur at distinct heights. Depth was primarily designed for 
automatically comparing feature depths at two similar sample sites (e.g., when analyzing etch 
depths on large numbers of identical silicon wafers).

Refer to the following sections on Depth analysis:

• Depth Theory: Section 3.4.1

• Depth Procedures: Section 3.4.2

• Depth Interface: Section 3.4.3

3.4.1 Depth Theory

The Depth command accumulates depth data within a specified area, applies a Gaussian low-pass 
filter to the data to remove noise, then obtains depth comparisons between two dominant features. 
Although this method of depth analysis does not substitute for direct, cross-sectioning of the 
sample, it affords a means for comparing feature depth between two similar sites in a consistent, 
statistical manner.

The display screen includes a top view image and a histogram; depth data is displayed in the results 
window and in the histogram. The mouse is used to resize and position the box cursor over the area 
to be analyzed. The histogram displays a Gaussian-filtered version of the data and is distributed 
proportional to its occurrence within the defined bounding box.

Histogram

Raw Data

Figure 3.4a displays a histogram (bottom graph) from raw depth data. Data points A and B are the 
two most dominant features, and therefore would be compared in Depth analysis. Depending upon 
the range and size of depth data, the curve may appear jagged in profile, with noticeable levels of 
noise. Data spikes are blue and correspond to specific depths of features on the sample surface.

Note: Color of cursor, data, and grid may change if user has changed the settings. 
Right-click on the graph and go to Color if you want to change the default 
settings. 
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Figure 3.4a   Depth Histogram

Correlation Curve

The Correlation Curve also displays for depth data. It is a filtered version of the Raw Data 
Histogram and is located on the Raw Data Histogram represented by a red line. Filtering is done 
using the Histogram filter cutoff parameter in the Input parameters box.The larger the filter 
cutoff, the more data is filtered into a Gaussian (bell-shaped) curve. Large filter cutoffs average so 
much of the data curve that peaks corresponding to specific features are unrecognizable. On the 
other hand, if the filter cutoff is too small, the filtered curve may appear noisy.

The Correlation Curve portion of the histogram presents a lowpass, Gaussian-filtered version of 
the raw data. The low-pass Gaussian filter removes noise from the data curve and averages the 
curve’s profile. Peaks which are visible in the curve correspond to features in the image at differing 
depths.

Peaks do not show on the correlation curve as discrete, isolated spikes; instead, peaks are 
contiguous with lower and higher regions of the sample, and with other peaks. This reflects the 
reality that features do not all start and end at discrete depths. 

When using the Depth View for analysis, each peak on the filtered histogram is measured from its 
statistical centroid (i.e., its statistical center of mass). 

Using the Grid Display

Measurement cursors for histogram are automatically positioned based on the numerical values 
selected in the Input fields. Right-clicking on the grid will bring up the Grid Parameters menu 
(see Figure 3.4b) and allow you to make the following changes:

30 60 90 1200
Depth (nm)

3

2

1

A
B

A

B
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Figure 3.4b   Grid Parameters Menu

Color Allows operator to change the color of the:

• Curve (data)

• Text

• Background

• Grid

• Minor Grid

• Markers

Filter Typically used for a Profiler Scan.

• Type—Select None, Mean (default), Maximum, or Minimum

• Points—Select 4k, 8k (default), 16k, or 32k

Minor Grid Places a minor grid in the background of the Vision window.

Scale Allows user to auto scale, set a curve mean, or set their own data 
range

Line Style For each curve, the operator can choose a connect, fill down, or point 
line.

User Preferences Restore—Reverts to initial software settings

Save—Saves all changes operator has made during this session. This 
becomes the new default settings.

Copy Clipboard Copies the grid image to the Microsoft Clipboard

Print Prints out the current screen view to a printer

Export Exports data in bitmap, JPEG or XZ data format

Active Curve Determines which curve you are analyzing
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3.4.2 Depth Procedures

1. If no workspace is present, open a new workspace (File > New Workspace).

2. Open the image you wish to analyze (File > Open > Captured Data File) or double click on 
the browse view image. 

3. In the workspace, position the cursor on the file name and right-click to access a functions 
pop-up menu.

Figure 3.4c   Functions Menu

4. In the pop-up menu, select Add View > Plane Fit.

5. You can view the Depth View using one of the following methods:

• Right-click on the image name in the Workspace and select Add View > Depth from 
the popup menu.

                                     Or

• Select Analyze > Depth from the menu bar.

                                     Or

• Click the Depth icon in the upper toolbar. 

6. Using the mouse, left-click and drag a box on the area of the image to analyze. 
The Histogram displays the depth correlation on this specified area.

Note: If no box is drawn, by default, the entire image is selected.

7. Adjust the Minimum Peak to Peak to exclude non relevant depths.

8. Adjust the Histogram Filter Cutoff parameter to filter noise in the histogram as desired.

9. Note the results.
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Note: To save or print the data, run the analysis in an Auto Program 
(see Section 3.9).

Figure 3.4d   Depth Interface

3.4.3 Depth Interface

The Depth interface includes a captured image, Input parameters, Results parameters and a 
correlation histogram (see Figure 3.4e).

Figure 3.4e   Depth Histogram
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Depth Input Parameters

The depth input parameters below define the slider cursor placement for determining the exact 
depth of a feature.

Results Parameters:

Number of Histogram Bins The number of data points, ranging from 4 to 512, which result from the fil-
tering calculation.

Histogram Filter Cutoff Lowpass filter which smooths out the data by removing wavelength compo-
nents below the cutoff. Use to reduce noise in the Correlation histogram.

Min Peak To Peak Sets the minimum distance between the maximum peak and the second 
peak marked by a cursor. The second peak is the next largest peak to meet 
this distance criteria.

Lowest Peak The left (smaller in depth value) of the two peaks chosen by the cursors. 
Value used to define how much of the left peak is included when calculating 
the centroid. At 0 percent, only the maximum point on the curve is 
included. At 25 percent, only the maximum 25 percent of the peak is 
included in the calculation of the centroid. 

Highest Peak The right (larger in depth value) of the two peaks marked by the cursors. 
Value used to define how much of the right peak is included when calculat-
ing the centroid. At 0 percent, only the maximum point on the curve is 
included. At 25 percent, only the maximum 25 percent of the peak is 
included in the calculation of the centroid.

Peak to Peak Distance Depth between the two data peak centroids as selected using the line cur-
sors.

Minimum Peak Depth The depth at which the smaller of the two peaks occurs.

Maximum Peak Depth The depth at which the larger of the two peaks occurs.

Depth at Histogram Max Depth at the maximum peak on the histogram.

Number of Peaks Found Total number of peaks included within the data histogram.
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3.5 Power Spectral Density

The Power Spectral Density (PSD) function is useful in analyzing surface roughness. This 
function provides a representation of the amplitude of a surface’s roughness as a function of the 
spatial frequency of the roughness. Spatial frequency is the inverse of the wavelength of the 
roughness features. 

The PSD function reveals periodic surface features that might otherwise appear “random” and 
provides a graphic representation of how such features are distributed. On turned surfaces, this is 
helpful in determining speed and feed data, sources of noise, etc. On ground surfaces, this may 
reveal some inherent characteristic of the material itself such as grain or fibrousness. At higher 
magnifications, PSD is also useful for determining atomic periodicity or lattice.

Refer to the following Power Spectral Density sections:

• NanoScope PSD Measurements:  Section 3.5.1

• PSD and Surface Features:  Section 3.5.2

• PSD and Flatness:  Section 3.5.3

• Performing a Spectral Density Analysis:  Section 3.5.4

• Changing Parameters of the Spectrum Plot:  Section 3.5.5

3.5.1 NanoScope PSD Measurements

The Power Spectral Density function computes the following information for the image:

• Total power spectrum—Power is roughness amplitude squared, so power is in units of 
length squared for a topographic image. Power spectrum is a plot of power as a function 
of spatial wavelength or frequency.

• 1D PSD—A one dimensional power spectral density. Power spectral density is a plot of 
the density, in spatial frequency space, of the power spectrum. Its units are length 
squared divided by a one dimensional frequency, or 1 over length, which is length 
cubed. A 1D PSD can be calculated in either the X direction of the data or in the Y 
direction.

• 1D isotropic PSD—A different version of a one dimensional power spectrum.

• 2D isotropic PSD—A two dimensional power spectral density. Its units are length 
squared divided by a two dimensional frequency, or 1 over length squared, which is 
length to the fourth power. This is isotropic in the sense that it is an average taken over 
all directions in the data.

• RMS roughness values—Since the RMS roughness is the square root of the integral of 
the PSD, over some wavelength or frequency interval, this calculation can be 
conveniently done when one has the PSD.
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3.5.2 PSD and Surface Features

Consider the image in Figure 3.5a.

Figure 3.5a   Waveform Surfaces

This synthetic surface consists of essentially two dominant wave forms: a long period waveform 
along the X-axis, and a shorter period waveform along the Y-axis. A 2 dimensional power spectral 
density plot consists of two dominant spikes (one for each dominant wavelength), plus some 
number of extra wavelengths inherent within the image. (These extra wavelengths may appear due 
to fine surface features and/or side bands of the dominant wave forms.) Because of the sinusoidal 
nature of the composite wave form, a relatively small set of spectral frequencies suffices to describe 
the entire surface. By contrast, an image comprised of angular (saw-toothed or square) waveform 
contains more spatial frequency components.

Over a given range of spatial frequencies the total power of the surface equals the RMS roughness 
of the sample squared. 

The frequency distribution for a digitized profile of length L, consisting of N points sampled at 
intervals of do is approximated by:

Where i = √-1, and frequencies, f, range from  to . Practically speaking, the algorithm used 

to obtain the PSD depends upon squaring the FFT of the image to derive the power. Once the 
power, P, is obtained, it may be used to derive various PSD-like values as follows:
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The terms used in the denominators above are derived by progressively sampling data from the 
image’s two-dimensional FFT center (see Figure 3.5b).

Figure 3.5b   Progressive Data Sampling

Each sampling swings a “data bucket” of given frequency f. Since samples are taken from the 

image center, the sampling frequency, f, is limited to , where N is the scan size in pixels. This 

forms the upper bandwidth limit (i.e., the highest frequency or Nyquist frequency) of the PSD plot. 
The lower bandwidth limit is defined at 1/L.

3.5.3 PSD and Flatness

PSD is used increasingly as a metrology tool for evaluating extremely flat surfaces, such as 
polished or epitaxial silicon. Generally, the desired surface is expected to adhere to certain PSD 
thresholds, signifying it meets a specified flatness criterion. 

The main advantage gained over traditional RMS specifications is that PSD flatness is qualified 
through the full spectral range of interest. For example, one may specify spectral thresholds at 
frequencies measured on the atomic scale, thus ensuring surfaces consist largely of uniform 
lattices. Setting the precise thresholds for various materials remains a matter of debate.

Consider the image of epitaxial gallium arsenide in Figure 3.5c.

Figure 3.5c   Epitaxial Gallium Arsenide Image

f = 1 pixel f = 2 pixels f = 3 pixels f = 4 pixels

∆f

N 2⁄
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This surface is comprised of “terraces” formed from the material’s natural lattice structure; each 
terrace is one atomic monolayer thick and is spaced at fairly regular intervals. This degree of 
flatness is handily evaluated with PSD, as the terraces produces a spectral spike corresponding to 
their spacing wavelength. A PSD plot for this type of surface generally takes the form shown in 
Figure 3.5d.

Figure 3.5d   PSD Plot for Terraced Sample

This tapered PSD plot is characteristic of flat, isotropic surfaces. Longer wavelengths are present up 
to the scan width, and are accompanied by uniformly decreasing powers of shorter wavelengths 
down to 2 pixels. On the plot shown above a spike stands out, corresponding to the wavelength 
spacing of the terraced features. Depending upon the qualitative standards of the person evaluating 
such a plot, this spike may exceed a threshold standard of flatness.

3.5.4 Performing a Spectral Density Analysis

To use the PSD Analysis function, perform the following procedures:

1. Select View > Browse from the menu bar, then open the image you wish to analyze by 
double-clicking it. 

2. You can view the PSD Analysis View using one of the following methods:

• Right-click on the image name in the Workspace and select Add View > PSD from the 
popup menu.

                                     Or

• Select Analyze > PSD from the menu bar.

                                     Or

• Click the PSD icon in the upper toolbar. 
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The PSD window opens to allow spectral density plotting on the Display Monitor (see Figure 3.5e). 

Figure 3.5e   PSD Analysis

Compute PSD Buttons

Once the PSD analysis window is opened, select the type of spectral density analysis you wish to 
perform by clicking the appropriate button above the Results window.

2D Isotropic—Executes a two-dimensional Power Spectral Density analysis.

Horizontal Axis—Executes a one-dimensional Power Spectral Density analysis along the X-axis.

Vertical Axis—Executes a one-dimensional Power Spectral Density analysis along the Y-axis.

The calculation begins as soon as the button is selected. The PSD and a table of values from the 
graph are shown in the Results window. Completion of the analysis will also result in a 
topographical histogram in the spectrum plot window (see Figure 3.5f).
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Figure 3.5f   Power Spectral Density Histogram

Results Display

The Results window displays the Name and Value of the procedures performed during a PSD 
analysis. The teal shaded area in the display window corresponds to the area designated by the teal 
cursor on the Power Spectral Density histogram, and the purple shaded area corresponds to the 
purple cursor. The operator can select to have a report generated for each Result displayed by 
toggling the Report window between Yes and No. Right-clicking in the Results window will open 
a popup menu (see Figure 3.5g) that allows you to set the result properties, select the parameters 
that will be displayed, and export the results data to the clipboard as a text file.

Figure 3.5g   Power Spectral Density Display
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Set Properties

The operator can select the wavelength properties for each Results window parameter by selecting 
Set Properties from the Results popup menu, which opens the Result Properties window (see 
Figure 3.5h), and entering the a Minimum Value and a Maximum Value. Checking the Report 
Value check box will change the Report window from No to Yes for that particular parameter. 
When PSD is being used as part of an AutoProgram (see AutoProgram:  Section 3.10), Checking 
the Check Limits box will cause the analysis to fail if the results are not within designated limits. 

Figure 3.5h   Result Properties Window

Select Displayed Parameters

The operator can select which Results will or will not be displayed in the Results window by 
Right-clicking in the Results window, selecting Toggle Show All from the popup menu, and 
checking or unchecking the appropriate boxes (see Figure 3.5i).

Figure 3.5i   Select Show All On/Off Check Boxes



Analysis Commands
Power Spectral Density

Rev. C Nanoscope Software 6.12 User Guide 125

Export Text

Selecting Export Text from the popup menu will copy the text from the Results window, in tab-
delimited text format, to the Windows clipboard. You may then paste it into a text or word 
processing program.

3.5.5 Changing Parameters of the Spectrum Plot

The Spectrum Plot window displays results of the PSD analysis (see Figure 3.5j). The window has 
two cursors whose color corresponds to the shaded areas in the Results window. You can move 
either of these cursors within the Spectrum Plot window by placing the cross hair cursor directly 
over the cursor, clicking and holding the left mouse button, and dragging the mouse to the left or 
right. You can also move both cursors simultaneously by left-clicking the mouse with the cross hair 
cursor anywhere between the two cursors and dragging to the left or right.

To change the parameters of the Spectrum Plot, right-click in the Spectrum Plot window at the 
bottom of the display and choose from the popup menu.

Figure 3.5j   Spectrum Plot Parameter Menu

Popup MenuTeal Cursor Purple Cursor Spectrum Plot
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Spectrum Plot Popup Menu Items

Color—Changes the colors of the curves, text, background, grid lines, minor grid lines (if 
selected), and the marker pairs (see Figure 3.5k).

Filter—Selects Filter type and points (see Figure 3.5l).

Minor Grid—Shows/hides minor grid lines

Figure 3.5k   Color Menu Items

Figure 3.5l   Filter Menu Items

Scale—Sets the vertical axis range, the center of the range, or allow the software to autoscale (see 
Figure 3.5m).

Line Style—Changes the line style of the Spectrum Plot graphical display (see Figure 3.5n).

User Preferences—You can either save all changes made to the graphical display, or restore 
previously saved settings (see Figure 3.5o). Save will result in all graphical displays maintaining 
any design changes made to this display.
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Copy Clipboard—Copies the graphical display only to the Windows clipboard, allowing it to be 
pasted into any compatible Windows program.

Print—Prints the graphical display only to a printer.

Export—Saves the graphical display as a JPEG graphic, a Bitmap graphic, or as an XZ Data file 
text, which can be read in a database program (i.e. Excel).

Active Curve—Changes the curve displayed when more than one curve has been plotted. (Does 
not occur in PSD).

Figure 3.5m   Scale Settings Dialog Box

Figure 3.5n   Line Style Display
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Figure 3.5o   User Preferences Menu

3.6 Roughness

The Roughness command generates a variety of statistics on surfaces, including classical 
roughness values, and peak and zero crossing data. “Image” statistics are reported for the entire 
image. “Box” statistics are reported only for the region you define within a cursor box. In addition, 
the data can be augmented with stopbands, (excluding features) to isolate desired analysis.

Refer to the following sections on Roughness:

• Roughness Theory:  Section 3.6.1

• Roughness Procedures: Section 3.6.2

• Roughness Interface: Section 3.6.3

Most industrial standards for roughness measurement call for planefitting data before calculating 
values. Planefitting applies a temporary, first-order planefit before calculating statistics. On many 
surfaces, especially those which are tilted, this yields different values from those seen in raw 
(unplanefitted) data. Moreover, peripheral features included within the analyzed region may 
produce cumulative results uncharacteristic of the feature(s) of interest. To ensure the best results, 
you should observe the following rules when using Roughness analysis:

• If the image shows signs of second- or third-order distortion (e.g., bow due to large 
scans on large scanners), apply a second- or third-order Flatten and Planefit to the 
image before using Roughness analysis.

• Isolate your analysis to specific areas of the image. This may be accomplished by using 
the box cursor in Roughness to analyze only select portions of the image.
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3.6.1 Roughness Theory

Regarding the effects of Planefitting on Roughness statistics—When Roughness analysis is 
applied to an image, statistical values are calculated according to the relative heights of each pixel 
in the image. Planefitting (used to correct images for tilt and bow) reorients these pixels in a 
manner which can affect roughness statistics dramatically on some surfaces. This is especially true 
of surfaces having broad, coplanar features. Planefitting can be applied at the time of file capture 
using Offline planefit from a Channel panel, or via the Analyze > Plane Fit function.

When Roughness analysis is applied to an image, the image data is automatically planefit 
beforehand. This is done to accord with ASME and ISO metrological standards. (Only the Raw 
mean parameter is exempt from this operation, being calculated from raw data only.) To avoid 
unexpected results due to planefitting, be certain to apply Roughness analysis only to the surface(s) 
of interest by utilizing a cursor box, or by scanning just the specific site of interest. Including 
peripheral features within an analyzed area may produce cumulative results uncharacteristic of the 
feature(s) of interest.

The relationship between the zero plane and the data also changes according to the setting of the 
Offline planefit parameter. If the Offline planefit parameter is set to None the offset is not 
removed from the data and it is very possible that the zero plane does not intersect the data. The 
other settings of the parameter subtract the average Z value from every point in the image so the 
data varies around the zero plane.

Regarding Basic Roughness Measurements—Average roughness (Ra) is one of the most commonly 
used roughness statistics. Figure 3.6a represents two surfaces having the same average roughness.

Similarly, a number of other roughness values are based upon least-squares calculations (e.g., RMS 
roughness, or Rq), and their algorithms are more concerned with a best fit of all height points than 
with the spatial frequency of features.

The surface of image A is represented as having a high frequency profile of features. Image B 
represents a separate surface having the same average feature height, but distributed at wider 
(lower-frequency) intervals. In terms of average and RMS roughness, both surfaces are equally 
rough. If you are interested in differentiating between the two, you must rely upon other statistical 
parameters such as Power Spectral Density.

Figure 3.6a   Basic Roughness Measurements

A B

Best-fit plane 
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3.6.2 Roughness Procedures

Example of Using Roughness Analysis

For general Roughness Analysis, complete the following procedures:

1. Select an image file from the file browsing window at the right of the main window. Double 
click the thumbnail image to select and open the image.

2. You can view the Roughness View using one of the following methods:

• Right-click on the image name in the Workspace and select Add View > Roughness 
from the popup menu.

                                     Or

• Select Analyze > Roughness from the menu bar.

                                     Or

• Click the Roughness icon in the upper toolbar. 

3. The Roughness View appears showing results for the entire image.

4. To perform Roughness measurements within an area, left-click and move the mouse to draw 
a measurement box. Click on the Execute button to calculate the Roughness inside the box.

5. To exclude an area, right-click in the image to access a pop-up menu and select Stop band. 
Using the mouse, draw a box around the area to be excluded by the stop band command. 
Click on the Execute button to calculate the Roughness outside the box.
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3.6.3 Roughness Interface

The Roughness View shows the image along with Input parameters and a Results window.

Note: Some parameters are reported only when certain subroutines are turned on. 

Figure 3.6b   Roughness Display

Results 
Parameters

Input
Parameters
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Input Parameters

Peak

The Peak feature, when switched On, isolates specified height portions of the image (peaks) from 
background data. Peaks are specified using the Peak Threshold parameters, either in terms of their 
absolute height or their deviation from the RMS value of all surface data, and relative to either the 
highest data point (Peak) or the mean (Zero). When Peak is turned On, portions of the image 
contained within the box cursor and falling within the specified boundaries are retained; all other 
data is removed.

Range or Settings—When Peak is turned On, the following subcommands are activated (see 
Figure 3.6c): 

When Peak is turned On, the following statistical parameters are turned on. All Peak parameters 
are calculated from the thresholds you define with the Peak subcommands.

• Rz

• Rz count

• Max peak ht (Rp)

• Av. Max ht (Rpm)

• Max depth (Rv)

• Av. max depth (Rvm)

When Peak is turned Off, statistics are not calculated.

Peak Threshold 
Reference

The Reference buttons select whether the threshold is defined relative to 
the Zero (lowest) value, or the tallest Peak in the selected region.

Peak Threshold 
Value Type

The Value Type determines whether the threshold is defined as an abso-
lute distance from the reference point in nanometers (Absolute value) or 
a percentage of the root-mean-square (Rms %) of the Z values.

Peak Threshold 
Value 

The Value is an absolute distance from the reference point in nanometers 
(Absolute value) or a percentage of the root-mean-square (Rms %) of the 
Z values.
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Figure 3.6c   Input On Parameters

Zero Crossing

A zero crossing is a point where the Z values go through zero regardless of slope. This value is the 
total number of zero crossings along both the X and Y center lines divided by the sum of the box 
dimensions.

Range or Settings—When Zero crossing is turned On and you click the Execute button, the 
number of zero crossings along the X and Y center lines of the box cursor is determined (see Figure 
3.6c). The number of zero crossings is divided by the sum of the lengths of the X and Y center lines 
and reported as the Line density.

When Zero crossing is turned Off, the zero crossing determination is not performed.

Peak Input Parameter ON

Zero Crossing 
Input Parameter ON
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Results Parameters

Statistics used by the Roughness routine are defined in this section. The terms are listed 
alphabetically. Most are derived from ASME B46.12 (“Surface Texture: Surface Roughness, 
Waviness and Lay”) available from the American Society of Mechanical Engineers, which should 
be consulted.

Rz This is the average difference in height between the five highest peaks and 
five lowest valleys relative to the Mean Plane. In cases where five pairs of 
peaks and valleys do not exist, this value is based on fewer points.

Av max Depth (Rvm) Average distance between the five lowest profile points and the mean data 
plane.

Av max ht (Rpm) Average distance between the five highest profile points and the mean data 
plane.

Box x Dimension The width of the Lx box cursor you define.

Box y Dimension The length of the Ly box cursor you define.

Image Mean Mean value of data contained within the image.

Image Projected surface 
area

Area of the image rectangle (X x Y).

Image Ra Arithmetic average of the absolute values of the surface height deviations 
measured from the mean plane. 

Image Raw mean Mean value of image data without application of plane fitting.

Image Rmax Maximum vertical distance between the highest and lowest data points in 
the image following the planefit.

Image Rq Root mean square average of height deviations taken from the mean 
image data plane, expressed as:

Image Surface area The three-dimensional area of the entire image. This value is the sum of 
the area of all of the triangles formed by three adjacent data points.

Image Surface Area 
Difference

Difference between the image’s three-dimensional Surface area and two-
dimensional projected surface area.

Image Z range Maximum vertical distance between the highest and lowest data points in 
the image prior to the planefit.

Ra
1
N
---- Zj

j 1=

N

∑=

Zi
2∑

N
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Kurtosis This is a non-dimensional quantity used to evaluate the shape of data 
about a central mean. It is calculated as

Graphically, kurtosis indicates whether data are arranged flatly or sharply 
about the mean.

Line Density The number of zero crossings per unit length on the X and Y center lines 
of the box cursor. A zero crossing is a point where the Z values go through 
zero regardless of slope. This value is the total number of zero crossings 
along both the X and Y center lines divided by the sum of the box dimen-
sions.

Max Depth (Rv) Lowest data point in examined region.

Max Height (Rmax) Maximum vertical distance between the highest and lowest data points 
within the cursor box.

Max Peak ht (Rp) Maximum peak height within the analyzed area with respect to the mean 
data plane.

Mean The average of all the Z values within the enclosed area. The mean can 
have a negative value because the Z values are measured relative to the Z 
value when the microscope is engaged. This value is not corrected for tilt 
in the plane of the data; therefore, plane fitting or flattening the data 
changes this value.

Mean Roughness (Ra) Arithmetic average of the absolute values of the surface height deviations 
measured from the mean plane within the box cursor:

Projected Surface Area Area of the selected data.

Raw Mean Mean value of image data within the cursor box you define without appli-
cation of plane fitting.

Rms (Rq) This is the standard deviation of the Z values within the box cursor and is 
calculated as:

where Zi is the current Z value, and N is the number of points within the 

box cursor. This value is not corrected for tilt in the plane of the data; 
therefore, plane fitting or flattening the data changes this value.

Rz Count Number of Surface peaks taller than the threshold.

Kurtosis
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3.7 Section

The Section command displays a top view image, upon which a single reference line may be 
drawn. The cross-sectional profiles and fast Fourier transform (FFT) of the data along the reference 
line is shown in separate windows. Roughness measurements are made of the surface along the 
reference line you define.

Section is probably the most commonly used Analyze command; it is also one of the easiest 
commands to use. To obtain consistently accurate results, ensure your image data is corrected for 
tilt, noise, etc. before analyzing with Section.

• Sectioning of Surfaces: Overview: Section 3.7.1

• Section Procedures: Section 3.7.2

• Section Interface: Section 3.7.3

Skewness Measures the symmetry of surface data about a mean data profile, 
expressed as:

where Rq is the Rms roughness. Skewness is a non dimensional quantity 

which is typically evaluated in terms of positive or negative. Where Skew-
ness is zero, an even distribution of data around the mean data plane is 
suggested. Where Skewness is strongly non-zero, an asymmetric, one-
tailed distribution is suggested, such as a flat plane having a small, sharp 
spike (> 0), or a small, deep pit (< 0).

Surface Area The three-dimensional area of the region enclosed by the cursor box. This 
value is the sum of the area of all of the triangles formed by three adjacent 
data points.

Surface Area Diff Difference between the analyzed region’s three-dimensional Surface area 
and its two-dimensional, footprint area.

Z Range Peak-to-valley difference in height values within the analyzed region.

Skewness
1

Rq
3
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3.7.1 Sectioning of Surfaces: Overview

Samples are sectioned to learn about their surface profiles. The Section command does not reveal 
what is below the surface—only the profile of the surface itself. When sectioning samples, you 
should first ascertain surface topology. Depending upon the topology and orientation of the sample, 
the results of Section analysis may vary tremendously.

Figure 3.7a   Section Analysis Orientation

In Figure 3.7a, the sample surface (a diffraction grating) is sectioned along three axes. Sections 1 
and 2 are made perpendicular to the grating’s rules, revealing their blaze and spacings. (Sections 1 
and 2 may be compared simultaneously using two fixed cursor lines, or checked individually with a 
moving cursor.) Section 3 is made parallel to the rules, and reveals a much flatter profile because of 
its orientation.

The Section command produces a profile of the surface, then presents it in the Section grid (see 
Figure 3.7b).

1

2       

3

3

2

1
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Figure 3.7b   Section Command Profile

Generally, Section analysis proves most useful for making direct depth measurements of surface 
features. By selecting the type of cursor (fixed, moving, or average), and its orientation to features, 
you may obtain:

• Vertical distance (depth), horizontal distance and angle between two or more points.

• Roughness along section line: RMS, Ra, Rmax, Rz.

• FFT spectrum along section line.

Features are discussed below. Refer to Roughness: Section 3.6 for additional information 
regarding roughness calculations.

Using the Grid Display

Measurement cursors for histogram and cross section views in depth and section are provided to the 
left and right of the Grid Display. You can bring the cursors into the grid by placing the mouse 
cursor onto the measurement cursors, clicking and holding the left mouse button, and dragging 
them onto the grid. When you place the mouse cursor onto a measurement cursor, the cursor will 
change to a horizontal or vertical double-arrow cursor , which indicates you can grab and drag 
this cursor.

Right-clicking on the grid will bring up the Grid Parameters menu (see Figure 3.4b) and allow 
you to make the following changes:

Color Allows operator to change the color of the

• Curve (data)

• Text

• Background

• Grid

• Minor

• Marker
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Figure 3.7c   Grid Parameters Menu

Filter Typically used for a Profiler Scan.

• Type—Select None, Mean (default), Maximum, or Minimum

• Points—Select 4k, 8k (default), 16k, or 32k

Minor Grid Places a minor grid in the background of the Vision Window.

Scale Allows user to auto scale, set a curve mean, or set their own data 
range

Line Style For each curve, the operator can choose a connect, fill down, or point 
line.

User Preferences Restore—Reverts to initial software settings

Save—Saves all changes operator has made during this session. This 
becomes the new default settings.

Copy Clipboard Copies the grid image to the Microsoft Clipboard

Print Prints out the current screen view to a printer

Export Exports data in bitmap, JPEG or XZ data format

Active Curve Determines which curve you are analyzing
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3.7.2 Section Procedures

1. Select an image file from the file browsing window at the right of the main window. Double 
click the thumbnail image to select and open the image.

2. You can view the Section View using one of the following methods:

• Right-click on the image name in the Workspace and select Add View > Section from 
the popup menu.

                                     Or

• Select Analyze > Section from the menu bar.

                                     Or

• Click the Section icon in the upper toolbar. 

3. Before doing a section analysis, ensure that the image is properly oriented by removing any 
tilt or bow. This is especially important if a high level of precision is to be employed in 
measuring the blaze angle.

4. To remove any tilt which might be present, select Analyze > Plane Fit. Set the Planefit 
Order parameter in the panel to 1st, then click the Execute button. The image is fitted to a 
plane (“leveled”) by fitting each scan line to a first-order equation, then fitting each scan line 
to others in the image. At this point, the image has not been appreciably altered, it has only 
been reoriented slightly.

5. In Section Analysis, to make a single-line section of the image, use the mouse to draw a line 
through the image, as in Figure 3.7d, and note the results.

6. Move the grid cursors along the section to make measurements.

Figure 3.7d   Mouse Drawing Line

Use the mouse to drag a line
cursor across the image.
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3.7.3 Section Interface

When a line is drawn on the image, the cross-sectional profile is displayed in the upper right 
window, and the FFT spectrum along the line is displayed directly below it (see Figure 3.7e). 

Note: To prevent undersampling, 1024 points along the selected line are used in the 
FFT calculation. The extra points are generated by interpolation.

The markers may be positioned in the profile and FFT spectrum. The results window at the bottom 
of the display lists roughness information based on the position of the presently selected reference 
markers. Each marker pair is color coordinated with the data in the results window.

Figure 3.7e   Section View

Grid Markers:

A pair of markers in the section grid and a single marker in the spectrum grid will automatically be 
drawn. Place the mouse cursor on the desired marker and left-click to move.

Marker pair 0 Default display color is blue. Slide the markers into the grid from the left or right side by 
clicking and holding the left mouse button. Data between the two markers will be dis-
played in the results window at the bottom of the display screen in blue.
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Results Parameters:

The standard deviation RMS (Rq), mean roughness (Ra), the maximum height (Rmax), and the 

10-point roughness (Rz) for the segment between the reference markers are also listed in the 

Results parameter grid. 

Results Parameters:

Marker pair 1 Default display color is red. Slide the markers into the grid from the left or right side by 
clicking and holding the left mouse button. Data between the two markers will be dis-
played in the results window at the bottom of the display screen in red.

Marker pair 2 Default display color is green. Slide the markers into the grid from the left or right side 
by clicking and holding the left mouse button. Data between the two markers will be 
displayed in the results window at the bottom of the display screen in green.

Spectrum Marker Displays the third slider cursor location along the spectral data (e.g., FFT Spectrum).

Length Length of the roughness curve.

RMS (Standard Devia-
tion)

Standard deviation of the Z values between the reference markers, calcu-
lated as:

where Zi is the current Z value, Zave is the average of the Z values 

between the reference markers, and N is the number of points between the 
reference markers.

 Ra (Mean Roughness) Mean value of the roughness curve relative to the center line, calculated 
as:

where L is the length of the roughness curve and f(x) is the roughness 
curve relative to the center line.

Rmax (Maximum Height) Difference in height between the highest and lowest points on the cross-
sectional profile relative to the center line (not the roughness curve) over 
the length of the profile, L.

Rz (Ten-Point Mean 
Roughness)

Average difference in height between the five highest peaks and five low-
est valleys relative to the center line over the length of the profile, L. In 
cases where five pairs of peaks and valleys do not exist, this is based on 
fewer points.

Freq. Cutoff (υυυυm) Frequency Cutoff measured in terms of a percentage of the root mean 
square.

RMS σ
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Changing the cursor on the FFT changes lc, the cutoff length of the high-pass filter applied to the 

data. The filter is applied before the roughness data is calculated; therefore, the position of the 
cutoff affects the calculated roughness values.

• RZ Count—number of peaks used for rz computation

• Radius—radius of circle fitted to the data between the cursors

• Radius Sigma—mean square error of radius calculation

• Surface Distance—distance measured along the surface between the cursors

• Horizontal Distance—horizontal distance between the cursors

• Vertical Distance—vertical distance between the cursors

• Angle—angle of the imaginary line drawn from the first cursor intercept to the second 
cursor intercept

• Spectral Period—spectral period at the cursor position

• Spectral Frequency—spectral frequency at the cursor position

• Spectral RMS Ampl.—amplitude at the cursor position

Mouse Operations for a Line Cursor:

• 1st click—Anchors the origin of a line segment and expands from the selected position, 
allowing a line segment to be drawn in any direction.

• 2nd click—Anchors the terminal point of the first (dashed) line segment and draws a 
moving reference line perpendicular to the fixed-line segment. The cross-sectional 
profile and the FFT along the reference line are displayed at this time. The position of 
the moving reference line tracks the movements of the mouse. When the mouse is 
stationary, the cross-sectional profile and the FFT of the data along the moving reference 
line is updated on the Display Monitor.

• Clicking on the center of the line and dragging moves the line on the image.

• Clicking on either end of the line rotates the line.
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Mouse Operations for Box Cursor (Right-Click Selection):

• 1st click—Anchors the origin of a box and “rubber bands” out from the center of the 
selected position.

• As a reference, the cursor positions show up on the center line in the box.

• 3rd click—Allows the box to be moved (cursor inside box), or resized (cursor on edge of 
box). Clicking on the corner allows the box to be resized in two directions.

• Holding the Shift button down while clicking on the box and dragging in a circular 
direction rotates the box.

3.8 XY Drift

Due to temperature differences, thermal lateral drift can occur between two successive images 
while scanning. Using Offline XY Drift analysis, the software can calculate the lateral shift 
between two images. You can also manually enter the drift.

3.8.1 Realtime XY Drift

You can capture two images in Realtime mode for later XY Drift analysis in Offline mode. 

1. You must be in Realtime mode and engaged (Realtime > Engage).

2. Select Realtime > XY Drift. The XY Drift Control dialog box displays (see Figure 3.8a).

Figure 3.8a   XY Drift Control Dialog Box

3. Enter the appropriate capture calibration settings and select Calibrate. Two images are 
captured with the number of lines designated, then the Offline XY Drift View opens (see 
Offline XY Drift Analysis:  Section 3.8.2).

Note: Both images must have the same microscope configuration and scanner 
calibration settings currently in use.
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Calibration Capture Settings

XY Drift Control Dialog Box Buttons

Down Frame
Captures lines from the top of the image to the bottom.

Up Frame
Captures lines from the bottom of the image to the top.

Number of Lines Designates the number of lines to capture. This number must be less than 
or equal to the Lines parameter in the Scan View > Scan tab panel.

Skip Frames Designates the number of frames to skip at the beginning of the scan.

X Correction Reports the current X correction value.

Y Correction Reports the current Y correction value.

Calibrate Stops any current drift correction and captures 2 images. After capturing 
the images, the Offline XY Drift View automatically displays.

Quit Closes the XY Drift Control dialog box.

Stop Drift Correction Stops any current drift correction.
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3.8.2 Offline XY Drift Analysis

Requirements

Two images from the same capture directory captured within 1 day of each other are required. The 
capture direction must be the same for both images (up or down), and the images must have the 
same microscope configuration and scanner calibration properties.

Procedure

To calculate XY Drift using the software:

1. Start with the earliest image and use one of the following methods to open the XY Drift 
Analysis View (see Figure 3.8b).

• Right-click on the image name in the Workspace and select Add View > XY Drift 
from the popup menu.

                                     Or

• Select Analyze > XY Drift from the menu bar.

                                     Or

• Click the XY Drift icon in the upper toolbar. 
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Figure 3.8b   XY Drift View

2. Use the Load Image button to browse for the subsequent image.

3. Click the Calculate Shift button. The software will calculate the shift of the second image 
relative to the first image.

4. The results display in the Results box. 

a. To apply the corrections in the Inputs box, click the Apply Correction button.

                                                             Or

b. You can also manually enter the correction values in the Inputs box. Click the Apply 
Correction button.

Note: Apply Correction effects Realtime by applying a drift correction to the 
Realtime images. Do not use Apply Correction if this is not your intent.
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Input Parameters

Statistics used by the XY Drift analysis are defined in this section. 

Results Parameters

Results of the XY Drift analysis are presented in this section.

XY Drift Buttons

Number of scan lines Specifies the number of lines to calculate.

Flatten Flattens both images before the shift is calculated. (Use the Undo Flatten 
button to reverse the flatten).

X Correction Specifies the amount of correction to apply to the X-axis of the scanner.

Y Correction Specifies the amount of correction to apply to the Y-axis of the scanner.

Second Image Defines the location of the second image used in the analysis.

X Shift Specifies the amount of calculated shift along the X-axis of the second 
image relative to the first.

Y Shift Specifies the amount of calculated shift along the Y-axis of the second 
image relative to the first.

Tested Correlation
Coefficient

Reports the correlation coefficient after correcting for the detected shift. A 
perfect correlation is 1.0. If the tested correlation coefficient is too low, 
then the calculation is not valid and should not be applied. You may need 
features that have more distinct contrast.

Raw Correlation
Coefficient

Reports the correlation coefficient between the two images prior to pro-
cessing.

Load Image Browse to open the second image in the right box.

Calculate Shift Compares left image to right image, and reports the shift statistics in the 
Results box.

Apply Correction Applies the correction in the Inputs box to the second image.

Undo Flatten Undo Flatten restores the image to its original form.
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3.9 Multiple Channel Analysis

It is often necessary to analyze more than one channel of data from the same scan. This can be done 
by opening a captured dual-scan or triple-scan image Offline. 

3.9.1 Dual-Scan Image

When you open a dual-scan image, the Channel 1 and Channel 2 images will appear side by side, 
with Channel 1 on the left and Channel 2 on the right, and the channel data will typically be 
shown below the left image. Click on the desired image to select the channel and the corresponding 
channel data will appear (see Figure 3.9a).

Note: The location of the Channel data may vary depending on window proportions.

Figure 3.9a   Captured Dual-Scan Image
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3.9.2 Triple-Scan Image

When you open a triple-scan image, the Channel 1 and Channel 2 images will typically appear 
side by side, with Channel 1 on the left and Channel 2 on the right, and the Channel 3 image will 
typically appear below the Channel 1 image. Channel data is now shown to the right of the 
Channel 3 image. Click on the desired image to select the channel and the corresponding channel 
data will appear (see Figure 3.9b).

Note: The location of the Channel data may vary depending on window proportions.

Figure 3.9b   Captured Triple-Scan Image

3.9.3 Analyzing Captured Multichannel Images

When performing any analysis of a multichannel scan, you may only analyze one channel at a time. 
Highlight the appropriate channel image by clicking on it, then select the desired Analysis View by 
any one of the following:

• Right-clicking on the image file name in the Workspace, selecting Add View, and 
clicking on the desired view.

• Selecting Analyze from the menu bar and clicking on the desired view.

• Clicking on the appropriate button in the button bar.
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Once you select the desired channel, and the appropriate view, a new window will open with only 
the image of the selected channel and you may start your analysis in accordance with the 
instructions in Section 3.1 through Section 3.3. If the image display in the view is not the desired 
channel, you can right-click on the image, go to Channel, and select the appropriate channel from 
the pop-up menu.

You can also print multichannel images simultaneously. All channels must be open in the same 
view, then select File > Print.

3.10 AutoProgram

An AutoProgram is a sequence of operations that may be applied automatically to at least one 
previously captured image. Typically, an AutoProgram is created to rapidly analyze a large number 
of images taken under similar conditions. Any image Modify or Analyze command may be 
included in an AutoProgram. Do the following to create an AutoProgram:

1. Select a directory, then an image file within it, from the file browsing window at the right of 
the NanoScope main window. Double-click its thumbnail to select and open the image. The 
image file name and the Offline icon, as well as a sunburst icon and the word “Image” are 
added to the Workspace, and the image opens in the viewing window (see Figure 3.10a).

Figure 3.10a   Open Image
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2. In the Workspace, right-click on the image file name or its Offline icon and select Create 
AutoProgram (see Figure 3.10b).

Figure 3.10b   Create AutoProgram

3. You are asked if you want to include the selected image to define the AutoProgram among 
the images processed by the AutoProgram (see Figure 3.10c). (Typically: “Yes.”) The Add 
Linked box should also be checked. When linking, any changes made to the currently active 
view will then alter any linked views.

Figure 3.10c   Include Selected Image Box

4. In the AutoProgram Results View (see Figure 3.10d):

a. Right-click on Autoprogram, under the image file name or icon appearing on the line 
under Run Group. 

b. Click Add View. 

c. Click the view of an Analyze or Modify command to be performed first by the 
AutoProgram. 
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d. Repeat for additional views (in Figure 3.10a, Flatten, Depth then Roughness 
operations will be performed).

Note: Example specifications of the Flatten, Depth and Roughness commands for 
inclusion in an AutoProgram are described next. Similar actions apply to 
include other Offline Analyze and Modify commands in an AutoProgram.

Figure 3.10d   Add Views to be Included in an AutoProgram

3.10.1 Example command: Flatten

To open the Flatten View: 

1. Click the command name or icon that has been added to the Run Group Autoprogram. 

2. Click in the image and drag open a box over features in the image that are to be excluded 
from the polynomial fit calculations (see Figure 3.10e). Typically, only featureless areas are 
used for flattening an image. 

3. On the right of the Flatten View, set parameter values to apply for all images operated on by 
the AutoProgram. 

4. Close the Flatten View.
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3.10.2 Example command: Depth 

To open the Depth View: 

1. Click the command name or icon that has been added to the Run Group Autoprogram. 

2. Click in the image and drag open a box over an area that contains a height step (see Figure 
3.10g). 

3. On the right of the Depth View, set parameter values that will apply for all images operated 
on by the AutoProgram. 

4. Close the Depth View.

Figure 3.10e   Specify a Flatten Operation
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Figure 3.10f   Specify a Depth Measurement
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3.10.3 Example command: Roughness

To open the Roughness View: 

1. Click the command name or icon that has been added to the Run Group Autoprogram. 

2. Click in the image and drag open a box over an area where you would like the sample surface 
condition analyzed (see Figure 3.10g). 

3. On the upper right of the Roughness View, set parameter values that will apply for all 
images operated on by the AutoProgram. 

4. On the lower right of the Roughness View, select what measurements to report. 

5. Close the Roughness View.

Figure 3.10g   Specify a Roughness Measurement for Inclusion in an AutoProgram
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3.10.4 Running AutoProgram

Once all commands are included in the AutoProgram list and their action specified, you are ready to 
run AutoProgram.

1. Click the Add Files button in the AutoProgram Results View (see Figure 3.10h). The Add 
Files dialog box appears.

2. In the Add Files dialog box, select the Link Files box to have the same AutoProgram 
instructions apply to each file. Select files of interest and click Add to have the selected files 
included when the AutoProgram is run. Hold down the Shift key to select a consecutive 
group of files or the Control key to select more than one individual file.

3. In the AutoProgram Results View, check the Hide View box if you don’t want the images 
displayed, as they are automatically analyzed by the AutoProgram. If you want to see the 
images processed during AutoProgram execution, leave Hide View unchecked. Increasing 
the value in Computation Time allows more time to view operations during Autoprogram 
execution.

Figure 3.10h   Add Files Dialog Box
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4. Click the Run button in the AutoProgram Results View to start the AutoProgram.

Note: The RUN button toggles to display Stop while the AutoProgram is running. 
Click it if you need to stop the process before it is completed. Clicking the Run 
button again restarts the AutoProgram at the first image.

5. Upon completion, the data appears in the Log File View property sheet (see Figure 3.10i).

Figure 3.10i   Log File View Property Sheet

6. If you close the Autoprogram Results View without saving the Autoprogram, you will be 
prompted to save the Autoprogram as an .apg file.

7. To save the log file, select the Save Log button in the Log File View.

8. You can print the Autoprogram results and also save the results as tab delimited text.
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