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Chapter 4   Modify Commands

The Modify commands are in the lower portion of the Analyze menu. Analyze appears in the menu 
bar once an image is open/active. It also appears in the Add View submenu and is accessible with a 
right-click on the image name in the workspace. Modify commands are used to eliminate noise, 
and correct for bow and tilt. These operations process the captured/stored image, then produce 
another (modified) version.

Please refer to the following analysis commands available on the NanoScope software:

• Flatten: Section 4.1

• Plane Fit: Section 4.2

• Lowpass Section 4.3

• Erase Scan Lines: Section 4.4

• Median: Section 4.5
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4.1 Flatten

The Flatten command eliminates unwanted features from scan lines (e.g., noise, bow and tilt). It 
uses all unmasked portions of scan lines to calculate individual least-square fit polynomials for 
each line. 

Flatten is useful prior to image analysis commands (e.g., Depth, Roughness, Section, etc.) where 
the image displays a tilt, bow or low frequency noise, which appear as horizontal shifts or stripes in 
the image. 

Figure 4.1a   Image Flattened

Bow in Image

Bow Removed



Modify Commands
Flatten

Rev. C Nanoscope 6.12 User Guide 161

4.1.1 Flatten Theory

The Flatten command is a filter that modifies the data to delete low frequency noise and remove tilt 
from an image. Each line is fit individually to center data (0th order) and remove tilt (1st order), or 
2nd or 3rd order bow. A best fit polynomial of the specified order is calculated from each data line 
and then subtracted out. In some cases, the stopband (box cursor to exclude features) can be used to 
remove regions of the image from the data set used for the polynomial fits. Click on the image to 
start drawing a stopband box. Right-click on a box to delete it or change its color. 

Flatten Polynomials

The polynomial equations calculate the offset and slope, and higher order bow of each line for the 
data (see Table 4.1a).

Table 4.1a   Flatten Polynomials

Order Polynomial Explanation

0 z = a Centers data along each line.

1 z = a + bx Centers data and removes tilt on each 
line [i.e., calculates and removes off-
set (a) and slope (bx).

2 z = a + bx + cx2 Centers data and removes the tilt and 
bow in each scan line, by calculating 
a second order, least-squares fit for 
the selected segment then subtracting 
it from the scan line.

3 z = a + bx + cx2 + dx3 Centers data and removes the tilt and 
bow in each scan line, by calculating 
a third order, least-squares fit for the 
selected segment then subtracting it 
from the scan line.
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4.1.2 Flatten Procedures

For an image that contains a number of noisy scan lines, use the Flatten command to correct the 
problem.

1. Open the image. Note disjointed scan lines which are misaligned along the Z-axis (some are 
high and some are low). This effect somewhat resembles an unshuffled deck of cards when 
viewed on-edge or appears as horizontal streaks or bands. The image may have bow along its 
Y-axis. 

Figure 4.1b shows an image file in its original, raw form as an example for the Flatten command. 
Many of the image’s scan lines are disjointed along the Z-axis. 

Figure 4.1b   Raw Image of Syndiatatic Polystyrene (500nm)

Top View of Image to Flatten                                         Surface Plot of Image showing Bow
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2. You can view the Flatten View using one of the following methods:

• Right-click on the image name in the Workspace and select Add View > Flatten from 
the popup menu.

                                     Or

• Select Analyze > Flatten from the menu bar.

                                     Or

• Click the Flatten icon in the upper toolbar. 

3. Set the Flatten order value to 0. This removes the scan line misalignment.

4. Click on Execute to initiate the Flatten command. The flattened image appears on the 
display screen.

Note: Figure 4.1c shows the same image file after using a zero-order Flatten (Flatten 
order = 0). The scan lines are now aligned.

Figure 4.1c   Flattened Image of Syndiatatic Polystyrene (500 nm)

5. To see a variety of effects using the Flatten command, enter different Flatten order values. 
Each new change may be undone by clicking on the Reload button.

Top View of Flattened Image Surface Plot View of Flattened Image
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4.1.3 Flatten View Interface

Click Analyze in the menu bar and select Flatten, or click on the Flatten icon in the button bar. A 
series of parameters appear in the Flatten View, allowing the order of the equation to be selected 
and display parameters to be adjusted to your preference.

Figure 4.1d   Flatten View
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 Input Parameters:

Flatten Order 

Flatten Order selects the order of the polynomial calculated and subtracted from each scan line.

Range and Settings:

Buttons on the Flatten Panel 

Flatten Order Flatten Order selects the order of the polynomial calculated and sub-
tracted from each scan line.

Range and Settings:

• Zero Order (0)—Removes the Z offset between scan lines by sub-
tracting the average Z value for the unmasked segment from every 
point in the scan line.

• First Order (1)—Removes the Z offset between scan lines, and the 
tilt in each scan line, by calculating a first order, least-squares fit for the 
unmasked segment then subtracting it from the scan line.

• Second order (2)—Removes the Z offset between scan lines, and the 
tilt and bow in each scan line, by calculating a second order, least-
squares fit for the unmasked segment then subtracting it from the scan 
line.

• Third order (3)—Removes the Z offset between scan lines, and the 
tilt and bow in each scan line, by calculating a third order, least-squares 
fit for the unmasked segment then subtracting it from the scan line.

Flatten Z Thresholding 
Direction

Specifies the range of data to be used for the polynomial calculation 
based on the distribution of the data in Z:

Range or Settings:

• Use Z >= —Uses the data whose Z values are greater than or equal to 
the value specified by the Z thresholding %.

• Use Z <—Uses the data whose Z values are less than the value speci-
fied by  the Z thresholding %.

• No thresholding—Disables all thresholding parameters.

Flatten Threshold for Applies the Thresholding values for the whole image or each line inde-
pendently.

Range or Settings:

• The whole image

• Each line

Flatten Z Threshold % Defines a Z value as a percentage of the entire Z range in the image (or 
data set) relative to the lowest data point.

Execute Initiates the command, based on the order selected.

Reload Restores the image to its original form.
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4.2 Plane Fit

The Plane Fit command calculates a single polynomial of a selectable order for an image and 
subtracts it from the image. The Plane Fit operation can be applied to either or both of the XY 
directions.

Box cursors, or passbands, allow specific points to be used in the calculation of the polynomial. 
Click on the image to start drawing a passband box. Right-click on a box to delete it or change its 
color.

Figure 4.2a illustrates an image with tilt and bow which could affect the analysis of the surface 
data.

Figure 4.2a   Visual Representation of Plane Fit

                                    

Tilt of Sample Surface 3rd Order Plane Fit
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4.2.1 Fitted Polynomials

Refer to Table 4.2a to view the polynomials that calculate the best plane fit for the images in the 
Plane Fit Auto function.

Table 4.2a   Plane Fit Auto Equations

Order Variable Polynomial Equation

0 X z = a

Y z = a

XY (Add Higher Order Cross 
Terms for XY OFF)

z = a

XY (Add Higher Order Cross 
Terms for XY ON)

z = a

1 X z = a + bx

Y z = a + by

XY (Add Higher Order Cross 
Terms for XY OFF)

z = a + bx + cy

XY (Add Higher Order Cross 
Terms for XY ON)

z = a + bx + cy + dxy

2 X z = a + bx + cx2 

Y z = a + by + cy2

XY (Add Higher Order Cross 
Terms for XY OFF)

z = a + bx + cy + dxy + ex2 + fy2

XY (Add Higher Order Cross 
Terms for XY ON)

z = a + bx + cy + dxy + ex2  + fy2+ gxy2 + hx2y + 

ix2y2

3 X z = a + bx + cx2 + dx3

Y z = a + by + cy2 + dy3 

XY (Add Higher Order Cross 
Terms for XY OFF)

z = a+ bx + cy + dxy + ex2 + fy2 + gxy2 + hx2y + 

jx3 + ky3

XY (Add Higher Order Cross 
Terms for XY ON)

z = a + bx + cy + dxy + ex2 + fy2+ gxy2 + hx2y + 

ix2y2 + jx3 + ky3 + lxy3 + mx2y3 +nx3y3 +ox3y + 

px3y2
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4.2.2 Plane Fit Procedures

Use Plane Fit to correct the image distortion as follows:

1. Open an image file from the menu bar (File > Open > Image) or through Browse (View > 
Browse), then double click on the image.

2. You can view the Plane Fit View using one of the following methods:

• Right-click on the image name in the Workspace and select Add View > Plane Fit 
from the popup menu.

                                     Or

• Select Analyze > Plane Fit from the menu bar.

                                     Or

• Click the Plane Fit icon in the upper toolbar. 

Note: The Plane Fit input parameters appear along with the top view image. 

3. Select X, Y, or XY.

4. Select the Order.

5. Select Execute.

6. Notice that the image distortion is removed, reflecting a flat, planar profile. 

Figure 4.2b   Saddle Image Before Plane Fit
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Figure 4.2c   Plane Fit View

Figure 4.2d   Plane Fit Image



Modify Commands
Plane Fit

170 Nanoscope 6.12 User Guide Rev. C

Now, experiment with this image to explore the range of Plane Fit capabilities. Try the following:

• Change the Planefit order value to see its effects. Notice that there is a vast difference 
between a value of 1, 2 or 3.

• Try plane fitting in one axis (for example, X), but not the other. This generally keeps 
whatever distortions are presently oriented along the unused axis. For example, the 
image can be straightened along its Y axis, while leaving the X axis strongly bowed.

• Try using a different Planefit order for the X and Y axis (for example, a setting of 3 for 
X, but a setting of 1 for Y.) This is similar to using one axis, but not the other.

• Compare the effect of Plane Fit with Flatten. Notice that each command has a 
significantly different impact upon this image; although, the difference is less noticeable 
for some other types of images.
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4.2.3 Plane Fit Interface

The Plane Fit dialog box (see Figure 4.2e) allows the display parameters and the Planefit order to 
be adjusted to your preferences. 

Figure 4.2e   Plane Fit Inputs Dialog Box
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 Buttons on the Plane Fit Window:

Input Parameters:

Execute  Initiates the plane fit operation.

Reload Restores the image to its original form.

Planefit order Selects the order of the plane calculated and subtracted from the image.

Z Thresholding direc-
tion

Specifies the range of data to be used for the polynomial calculation based on 
the distribution of the data in Z:

Range or Settings:

• Use Z > = —Uses the data whose Z values are greater than or equal to the 
value specified by  the Z thresholding %.

• Use Z <—Uses the data whose Z values are less than or equal to the value 
specified by  the Z thresholding %.

• No Thresholding—Disables all thresholding parameters.

Z Thresholding Per-
cent

Defines a Z value as a percentage of the entire Z range in the image (or data 
set) relative to the lowest data point.

Add Higher Order 
Cross Terms

Turning this on adds higher order cross terms to the polynomial fit when XY 
is chosen (see Table 4.2a).
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4.3 Lowpass

The Lowpass modify command applies spatial filtering to a captured image, suppressing high 
spatial frequency components. Each pixel in an image is replaced with the average value of the 
3 × 3 pixels centered on it.

1. Select an image file from the file browsing window at the right of the main window. Double-
click the thumbnail image to select and open the image.

2. You can view the Lowpass View (see Figure 4.3a) using one of the following methods:

• Right-click on the image name in the Workspace and select Add View > Lowpass from 
the popup menu.

                                     Or

• Select Analyze > Lowpass from the menu bar.

                                     Or

• Click the Lowpass icon in the upper toolbar. 

Figure 4.3a   Lowpass Image Display

3. Click the Execute button in the Lowpass window to apply the low pass function to the copy 
of the image in both windows.

4. To restore the unprocessed image, click the Reload button.

Note: There are no parameter controls for the Lowpass modify command.
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4.4 Erase Scan Lines

The Erase modify command is a retouching function for editing images. Previously, horizontal 
lines could be replaced with an interpolation from the adjacent lines. In Version 6, the capability is 
extended to rectangular areas as well.

1. Select an image file from the file browsing window at the right of the main window. Double 
click the thumbnail image to select and open the image.

2. Open the Erase View (see Figure 4.4a) using one of the following methods:

• From the menu bar, click Analyze > Erase.

                                     Or

• Right-click on the Image file name in the Workspace and select Add View > Erase 
from the menu.

                                     Or

• Click the Erase icon in the upper toolbar. 

Figure 4.4a   The Erase Option in the Analyze Menu
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3. A separate window opens, also displaying the image. Right-click in the image to display the 
Erase options menu (see Figure 4.4b). Select either Horizontal Line or Area and a check 
mark will appear. The option chosen will remain checked until another selection is made.

4. Click anywhere within the image to define a horizontal line, or click and drag in the image to 
define a box to be replaced.

Figure 4.4b   Erase Options Menu
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5. Click the Execute button to perform the interpolation.

Figure 4.4c   Effect of the Erase Interpolation on a Rectangular Area

6. Right-click on an Erase feature of a modified image (either line or box) for options to 
complete the operation. Click Delete to erase the dashed construction lines from the display 
of the selected feature. Click Clear All to eliminate all construction lines from the display, 
while retaining the modifications to the image.

7. To eliminate all trace of Erase activity to an image, click the Reload button while the image 
is still open in the Erase panel.

Before After
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4.5 Median

The Median modify command is similar to Lowpass; it reduces the contributions of high spatial 
frequency, reducing contrast in regions of high contrast. For each pixel in an image, Median 
substitutes with the median pixel value of the n×n array of pixels centered around that pixel. The 
size of the filter’s sliding window pixel array is set under Inputs > Median order. Figure 4.5b 
illustrates the effect of three different size pixel arrays applied to the same image.

Figure 4.5a   # Different Pixel Arrays of the Same Image
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1. Select an image file from the file browsing window at the right of the main window. Double-
click the thumbnail image to select and open the image.

2. Open the Median View using one of the following methods to open a separate window 
which also displays the image (see Figure 4.5b):

• From the menu bar, click Analyze > Median.

                                     Or

• Right-click on the Image file name in the Workspace and select Add View > Median 
from the menu.

                                     Or

• Select the Median icon. 

3. Select the Median Order from the Inputs menu: 3×3, 5×5, 7×7, 9x9, or 11×11.

4. Click Execute to apply the Median filter.

5. Click Reload to start over.

Figure 4.5b   Median View
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